2

I get a lot of annoying spam calls and texts. I want my phone to only give me a sound notification when someone from my contacts list calls or texts me. So I turned on the Do Not Disturb mode, and selected the priories, so that I only get notifications from my contacts.

The problem with this, is that now none of my apps give me notifications. I still want to get notifications from certain apps, like Skype for instance. So I clicked on the app notifications, to select the apps that I want to override the do not disturb. But I am only given a few odd app choices, not all of my apps. (See photo) But if I turn off do not disturb, I get spam calls and texts all day, which is pretty annoying.

Can anyone help me figure out how I can get sound notifications from my contacts only (Call and Text), but still get other app notifications?

I appreciate anyone's help. Thanks!

enter image description here

2
  • Do you have non-stock OS, like Samsung? I'm on a Pixel and (1) the "do not disturb" app menu lists all the apps and (2) there's also a menu called "display options for hidden notifications" that lets me select "no sound from notifications" – mblakesley Mar 26 at 0:36
  • I don't think I have non-stock OS. I fixed the issue, with the answer below from svin83. But thanks for the comment. : ) – Ryan King Art Mar 26 at 17:39
1

Info

You could be better off with another approach like for example:

  1. Set the notification sounds for SMS and ringtone to an empty audio clip. (no sound)
  2. Add all your contacts to a contact group.
  3. Set your preferred SMS/ringtone sounds for that entire contact-group.

This may be better for long term use since it won't hide and silence notifications of all installed apps.

Note: This may depend on your phone make/model/firmware.

Answering your question

I'll use Skype as an example.

Open app info for skype
Settings->Apps->Skype

Notification settings
Select notifications, then tap the name of any notification category (not the toggle switch).

Then toggle (enable) the option named Ignore do not disturb at the bottom the list.

2
  • Thank you so much! This solved my problem! – Ryan King Art Feb 3 at 1:52
  • 1
    Glad I could help you out. – svin83 Feb 3 at 4:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.