0

I am using Windows 10 20H2, 64-bit, with CPU virtualization enabled.

I have enabled Virtual Machine Platform because I use Windows Subsystem for Linux. But I had not enabled Hyper-V when I installed BlueStacks.

I installed BlueStacks 4.0 via this executable: BlueStacksInstaller_4.260.0.1032_native_4176a437bc759281d8303dbcf40bdb72.exe,it automatically detects the settings of my computer and downloads the appropriate edition of BlueStacks.

After installation I started BlueStacks, and it starts fairly fast.

But I found the edition of BlueStacks I have installed is BlueStacks (Hyper-V), however I had not enabled it.

So I enabled Hyper-V in OptionalFeatures.exe, and restarted, and then I found out that it just won't finish starting up, it just stuck at displaying Starting BlueStacks Hyper-V, please wait.

The progress bar is very close to finish point, but it just refuses to go any further, like this:

enter image description here

Finally it said: Could not start the Engine.

enter image description here

I restarted the Engine multiple times and always succeeded in recreating the problem.

I then disabled Hyper-V and rebooted my computer, and I can use BlueStacks again.

However I also want to use Oracle VirtualBox, which requires Hyper-V.

So I uninstalled BlueStacks and downloaded the non-Hyper-V edition, tried to install it while Hyper-V is disabled, and it failed with error:

enter image description here

But Hyper-V is disabled:

PS C:\Windows\System32> Get-WindowsOptionalFeature -Online | where {$_.FeatureName -match "Hyper-V"}

FeatureName : Microsoft-Hyper-V-All
State       : Disabled

FeatureName : Microsoft-Hyper-V
State       : Disabled

FeatureName : Microsoft-Hyper-V-Tools-All
State       : Disabled

FeatureName : Microsoft-Hyper-V-Management-PowerShell
State       : Disabled

FeatureName : Microsoft-Hyper-V-Hypervisor
State       : Disabled

FeatureName : Microsoft-Hyper-V-Services
State       : Disabled

FeatureName : Microsoft-Hyper-V-Management-Clients
State       : Disabled

I have disabled Windows Defender and I am not using any anti-virus software, my computer has 12 GiB RAM and its CPU is Intel Core i5 4430 @ 3.00GHz;

How can I use BlueStacks with Hyper-V enabled?

3
  • I have to use BlueStacks because I want to use EKA2L1, but my android phone has a 32 bit OS and I can't successfully install EKA2L1 on it, EKA2L1 supports only 64-bit systems; I tried to use the Windows version, it crashes and says mf.dll, mfplat.dll, mfreadwrite.dll and mftranscode.dll were missing, I downloaded all these dlls and tried to run it again, only to be greeted by another crash: Can't create window! Check if your PC support at least OpenGL 3.1! My GPU is Intel HD Graphics 4600 and I don't have dedicated GPU...... – Xeнεi Ξэnвϵς Feb 4 at 5:35
  • Please do not put extra info in comments. Just edit your post instead. Emulators need special support for Hyper-V (which is also used by other Windows features like application sandboxing and others). Looks like BlueStacks does not yet support it. Other virtualization software like VirtualBox also have big problems when Hyper-V is active. – Robert Feb 4 at 8:27
0

Yes, this is because I have enabled Virtual Machine Platform and it implicitly enables Hyper-V, because Hyper-V is a native hypervisor, as long as it is enabled Windows boots as a virtual machine and can only access the emulated CPU and can't access the physical CPU, the emulated CPU doesn't support VT-x, so as long as Hyper-V is enabled performance of hosted hypervisors will decrease.

And I found out that Windows Defender Device Guard is also enabled and it also implicitly enables Hyper-V.

So I used these commands in elevated cmd to truly disable Hyper-V:

bcdedit.exe /set hypervisorlaunchtype off
dism /online /disable-feature /featurename:VirtualMachinePlatform
reg add HKLM:\System\CurrentControlSet\Control\DeviceGuard /v EnableVirtualizationBasedSecurity /t REG_DWORD /d 0
shutdown /r /t 0

After that I can't open BlueStacks (Hyper-V), so I uninstalled it and installed the version without Hyper-V, which is faster because of VT-x.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.