2

I have a Samsung Galaxy Note 9 and recently I have been experiencing a very weird problem. When connected to Wi-Fi on my home network, the internet frequently stops working. I would still be connected to Wi-Fi, but there would be no internet (little exclamation sign appears). Once I turn the Wi-Fi off and on again, it would start working fine again. This happens frequently (some times the internet only works for 5 minutes then I have to restart the Wi-Fi again). The weird part is, the problem only happens on my home Wi-Fi network, and it doesn't happen on any other devices in my home. So it basically only happens when my phone is connected to my home Wi-Fi. I tried forgetting the network, resetting networking settings on my phone, nothing worked. I am trying as much as possible not to try a factory reset. I am not even sure if the problem is with my phone or my router. Any thoughts?

4
  • Are there other device in your home WiFi network and do they show a similar behavior (to check if the problem is phone or WiFi related)? – Robert Feb 5 at 13:54
  • Yes there are many devices (laptops, android phones, iPhones). None of them show a similar problem. – Yosry Feb 5 at 13:55
  • I tried a guest network, it didn't work. My router only supports 2.4 ghz unfortunately. – Yosry Feb 5 at 15:27
  • 1
    @alecxs I tried a static IP, the same problem happens. – Yosry Feb 7 at 14:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.