2

I've gotten stuck trying to upgrade a Glorystar Nebula 15 kiosk Android tablet (as customized for the orphaned Flywheel spin-bikes) to a vendor-provided single-file Android 7.1 firmware image (7.20191202.115231.img, 715MB).

A special challenge here: this tablet has no physical buttons whatsever: no power, no volume controls, no home. (It simply turns on whenever power is supplied; there's a click power toggle inline on the DC power cord plugging into the back. It's got no battery for unplugged use.)

Following the vendor's instructions (using a Windows AndroidTool program 2.35), it was able to 'Switch' to detecting a LOADER device, and appeared to write firmware - but after a lack of progress ending on a log line mentioning 'Success', I disconnected & power-cycled in an attempt to view my hopefully-fresh-new-stock-Android7.1 tablet - and instead found it in a state where it never proceeds past a 'GS' logo boot screen.

Currently, from this GS screen:

  • the tablet only ever appears as "Found One ADB Device" in the Windows AndroidTool, whereas previously it could 'Switch' to "LOADER"
  • it can be detected via adb from MacOS – but oddly, not via adb inside the same Windows10 VM for which AndroidTool was sorta-working.and, adb shell commands give a error about the sh-path not being valid.
  • adb can reboot it into recovery mode - but without physical buttons, no navigation/selection from the recovery menu is yet possible, and it does not appear to adb or AndroidTool in this mode
  • adb can seemingly also reboot it into bootloader or fastboot mode; in this mode it no longer appears to MacOS adb, but does appear in MacOS fastboot devices list. However, attempting to connect the tablet while in this mode to Windows AndroidTool still only ever shows "Found One ADB Device" (or nothing)

I'm looking for any path out of this dead-end state that allows a re-attempt of the flashing the original vendor single-file firmware IMG, or other potential Android 7.1 firmwares. For example:

  • I've found a header on the motherboard with pins GND / PWR / HOME / ESC / V+ / V- / MENU / K2 / K1. However, hand-shorting PWR or V+ to GND with a small wire (alone or together, at the 'recovery' menu that's supposedly looking for vol-nav inputs or other times), has had no visible effect since the tablet's been in this state.

  • Can the vendor's single IMG be broken into the smaller more-specific parts that fastboot seems limited to flashing? Can applying those, or some other, smaller steps restore a true "Found One LOADER Device" mode, such that the AndroidTool might be able to make another attempt?

Etc – open to whatever gets Android 7.1 on this device, including, at this point, all-or-nothing gambits to resuscitate or brick it.

Any ideas?

0
+100

For your device you should use a touch based recovery as you don't have any buttons. If you don't found a pre-compiled recovery for your device, look for another recovery or compile your own. You can also try to use this library to compile the recovery. Once you've got your recovery follow these steps.

Enable Developer mode in Settings.

Turn on OEM unlocking.

Connect your phone with USB cable.

Allow computer to access ADB.

Now execute the following commands...

Reboot from ADB to bootloader.

adb reboot bootloader

Should reboot the device to fastboot mode.

You might need to know your unlock code.

fastboot oem get_unlock_data

You have to send this code to the OEM and they should give you another code.

After that you can try to unlock the bootloader.

fastboot oem unlock bootloader your_code_from_oem

This step is necessary for Motorola devices, but not sure about others.

Then you should flash a recovery.

fastboot flash recovery recovery.img

Make sure you're flashing the correct recovery.

Then reboot into recovery.

fastboot reboot recovery

This should boot up the touch based recovery.

If you're done with all these steps then you've successfully unlocked your bootloader and flashed a custom recovery on the device. Now you can wipe the device including the OS.

Note: when you lock/unlock your bootloader your userdata is automatically wiped. If you don’t want to flash a custom recovery that’s fine, just simply unlock and relock the bootloader.

2
  • Thanks, this is useful! However, I'm currently away from the problem device so can't yet try the steps for a couple days. Also, there's no TWRP clearly fit to my device, nor is it clear that the compile instructions include enough details/resources to build something for this device. (Right off the bat, they mention OS builds – like LineageOS or Omni – that are neither part of the current nor intended state of the tablet.) But, I've discovered its current state is in some sort of OEM lock, so your tips about that step are useful (and may require OEM followup.) … – gojomo Feb 16 at 8:43
  • As the bounty deadline is coming up, I'll award it, though I'm not sure yes this actually solves my problem. Is it the case that after achieving a touch-based recovery mode, that mode would then be able to apply the single 7.20191202.115231.img file somehow, in each of its segments – such as from an SD card? Or must it somehow be decomposed and flashed to each of the separate partitions using other adb/ fastboot commands? – gojomo Feb 16 at 8:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.