1

I have an old android tablet - Asus/Google Nexus 7 (2013) - which I would like to use with Touch Portal. The tablet was factory reset several years ago and has, I believe, the latest release of Android (6.0.1) that was officially released for it.

I've tried a couple of times to get signed in to my Google account on the device. It prompts me for my username and password and then appears to hang - currently over 24 hours as I write this.

I have a feeling that this is caused by 2 factor authentication which I have enabled on my account - the default of which is a security key, specifically a Yubico Yubikey 5 NFC.

I once saw a message about using a security key so I have attempted to use it via USB and NFC. When I tried this last time via NFC, I saw a new login in my Google Account at the same time but the screen still hangs.

I'm not prepared yet to disable 2 factor authentication (albeit temporarily) quite yet but may consider it if there really are no other options.

Screenshot of tablet showing greyed out screen and no prompt

UPDATE Here's the confirmation that my Yubikey was used during the attempt to login despite nothing showing on screen prompting such action and nothing happening afterwards.

Yubikey usage Nexus 7

6
  • What does your "recent Google activities" at myaccount.google.com show?
    – Robert
    Feb 9 '21 at 7:52
  • @Robert It's not showing anything related to the login and I'm unable to find it again now!
    – phuzi
    Feb 9 '21 at 10:14
  • I would assume that your main problem is that the installed Google services have not yet updated itself. Make sure the tablet is always on and connected to a Wifi with full Internet access and wait a few hours (up to a day). Usually google services should install latest update.
    – Robert
    Feb 9 '21 at 10:37
  • And... I can't update them via Play Store unless I add an account!
    – phuzi
    Feb 9 '21 at 10:41
  • As far as I know the play services update themselves independently of a logged in Google user. The only problem is that you can't trigger the update manually instead you have to wait that it happens automatically.
    – Robert
    Feb 9 '21 at 10:43
1

Thanks to @Robert who pointed me in the right direction.

Unfortunately Google Play services didn't update itself automatically even though it had been on for a couple of days. So... I resorted to downloading a recent version from apkmirror, found the right version for the 2013 Asus Nexus 7 (armeabi-v7a, Android 6.0+, nodpi).

It took a minute or so to install but it was successful, after which I attempted to login again. This time, after entering my password, I was prompted to choose how I wanted to use my security key to login. Chose NFC, and I'm in.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.