2

I have a strange problem on my Samsung J2 Android phone. Although apps like WhatsApp and some games which require Internet work, none of the Google Apps like Google, Chrome, YouTube and Play Store are working. Whenever I open the Google apps, it shows "Check your internet connection" although my mobile data is on. But, on connecting my phone to a Wi-Fi network, these apps work. How can I fix this?

P.S. One more important thing: When I open Chrome, I get a message saying ERR_PROXY_CONNECTION_FAILED.

5
  • 3
    Your carrier might be blocking Google domains. Do a ping and/or dig on few of the commonly accessed Google domains. Also check logcat to see what errors Google apps throw when a connection fails. – Irfan Latif Feb 17 at 17:48
  • @irfanLatif how do you do that? – AD-1 Feb 18 at 4:25
  • Does anyone else have a solution? I will definitely award the bounty to the one who solves my problem. – AD-1 Feb 18 at 6:04
  • 1
    In which country do you live and which mobile network provider do you use? If there is a man-in-the-middle attack (e.g. by your government) on the mobile network then Google services will not work because they use certificate pinning. Other apps will as ling as the used server certificate is trusted by the device. – Robert Feb 18 at 12:28
  • I live in India, but I don't think that's the case. – AD-1 Feb 18 at 13:53
1
+50

ERR_PROXY_CONNECTION_FAILED.

This obviously has to do something with proxies. Either you set a proxy through your cellular data setting or some application has put phone in tunneling (VPN etc).

And obviously google services are highly sensitive to proxy IPs. Check if your IP is what your ISP has provided. Google services are often buggy with cache so try clearing some cache as well.

Changing APNs might also work, sometimes Google might get sensitive of your real IP. Do a hotspot sharing and check google services with that IP on other devices.

6
  • Hi, thanks for your help. I am guessing that resetting my APNs will do it, but what does resetting an APN mean? Will it cause any problem in my phone? – AD-1 Feb 22 at 11:15
  • 1
    @AD-1 Hey,APNs are literally pre-sent configs which are sent by providers, most of time(at least in my country) you can prompt your ISP to resend APN through USSD. I highly recommend you to make a contact with ISP for this purpose. Ports,Protocols and proxies are set in APNs – iBUYPOWER Feb 22 at 11:23
  • Do you know about the same in India? What should we do in India about this? – AD-1 Feb 23 at 12:21
  • hey, I awarded you the bounty. Congrats! – AD-1 Feb 24 at 2:06
  • @AD-1 Hey! Thanks for that, this might be of a help check – iBUYPOWER Feb 24 at 8:37
3

Check if google domain is not blocked by the network you are using , also try resting network settings , and try to delete the configuration settings that has been provided by your service provider automatically and call the help line ask them to resend you the internet settings.

2

You can turn off data saver mode. And try to use Google apps. Your other apps are working. But you can reset network setting. You can change APN.

Go to setting / mobile network / Access point name. Every carrier has APN. You can try all APN.

Force stop google app and than start again. Clear cache and storage for apps.

1
  • Can you elaborate more? – AD-1 Feb 18 at 13:53
-2

i think auto sync is turn off, go to accounts and turn auto sync on

2
  • 3
    Chrome, YouTube and Play Store don't need sync to work. Plus, if sync was the problem it should be exhibiting when Wi-Fi was being used. The problem with OP is only when the device is using mobile data. – Firelord Feb 17 at 7:36
  • This is definitely not the problem. This is a recent problem for me, but my auto-sync has always been turned off. – AD-1 Feb 19 at 8:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.