1

I'm trying to pull down app from the phone, and see the files within
First I used App Inspector to get a package name.
Then few options to get the actual apk down, but no luck. So I"ve done

adb shell
pm list package health

so it listed Samsung Health as com.sec.android.app.shealth Then outside the shell I tried backup

adb backup -f SamsungHealth.ab com.sec.android.app.shealth

Provided PIN on the mobile, so it downloaded but the file is tiny 500b. I tried to tar it but no luck.

dd if=SamungHealth.ab bs=24 skip=1 | openssl zlib -d | tar -x

or

dd if=SamungHealth.ab bs=4K iflag=skip_bytes skip=24 | openssl zlib -d > SamungHealths.tar

but either say that zlib error (Fedora 32, with zlib and openssl installed and tar works normally otherwise

140635897317184:error:29065064:lib(41):bio_zlib_read:zlib inflate error:crypto/comp/c_zlib.c:400:zlib error:data error

I tried other option within adb shell

adb shell
run-as com.sec.android.app.shealth

error - run-as: package not debuggable: com.sec.android.app.shealth
so I couldn't even continue to go and see the folder

cd /data/com.sec.android.app.shealth
ls 
cp ....

to list files... I tried for several application not systemic, user installed but same issue


1.) So, Is it possible to see files of particular app at all if not rooted?
2.) Why backup so small even though each app had 150Mb + data?
3.) Any other way to open backup file, as it looks like is not a tar archive convertible?
Thanks

4
  • 1
    "Is it possible to see files of particular app at all if not rooted? ". No. See details here: Why are superuser permissions needed to acess /data partition?. What you are trying is not a genuine solution, but just a workaround which may work only on apps built with allowBackup attribute set. If it doesn't work, there's no other way. – Irfan Latif Feb 14 at 15:50
  • Thanks @IrfanLatif I was curious how come is possible to uninstall apps without root privileges, but it seems to me that apps don't actually get removed. They are however not listed any more via adb shell, but on the mobile still seen (probably just reset to factory default). So this USB debugging - via adb don't give you much extra permissions. I presume that other applications also can't have access to another existing application on the mobile. New app normally has to request some system permissions via API calls, but not actual access to files also. – Denis Feb 14 at 16:09
  • 1
    User (non-system) apps' data is completely removed if -k options is not passed to adb uninstall. APK file is also removed if the app is not installed for any other user (e.g. a work profile). // App installation is not handled by ADB or the app itself. There are privileged system components which perform [un]installation of the app. Explained in the already linked answer. // Yes, apps cannot have access to other apps' private data. – Irfan Latif Feb 14 at 16:17
  • try again with -system + -keyvalue flags (usage: adb backup [-f <file>] [-apk|-noapk] [-obb|-noobb] [-shared|-noshared] [-all] [-system|nosystem] [-keyvalue|-nokeyvalue] [<pkgname...>]). just a hint, leave password blank. this way you get unencrypted backup, plain zlib deflate which can be extracted with gzip (no java, openssl). another related issue android.stackexchange.com/q/143367 – alecxs Feb 14 at 20:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.