1

I'm trying to decompile an apk with the apk tools and I'm not getting it. When I run apktool -d myapp.apk it displays this error to me:

 Exception in thread "main" brut.androlib.AndrolibException: Invalid chunk type: expected=0x00000200, got=0x00000203
    at brut.androlib.res.decoder.ARSCDecoder.checkChunkType(ARSCDecoder.java:542)
    at brut.androlib.res.decoder.ARSCDecoder.readTablePackage(ARSCDecoder.java:88)
    at brut.androlib.res.decoder.ARSCDecoder.readTableHeader(ARSCDecoder.java:82)
    at brut.androlib.res.decoder.ARSCDecoder.decode(ARSCDecoder.java:48)
    at brut.androlib.res.AndrolibResources.getResPackagesFromApk(AndrolibResources.java:786)
    at brut.androlib.res.AndrolibResources.loadMainPkg(AndrolibResources.java:67)
    at brut.androlib.res.AndrolibResources.getResTable(AndrolibResources.java:59)
    at brut.androlib.Androlib.getResTable(Androlib.java:66)
    at brut.androlib.ApkDecoder.setTargetSdkVersion(ApkDecoder.java:236)
    at brut.androlib.ApkDecoder.decode(ApkDecoder.java:118)
    at brut.apktool.Main.cmdDecode(Main.java:170)
    at brut.apktool.Main.main(Main.java:76)

Can anyone help me with that? I would offer more reward does not yet

3
  • 3
    Known issue with APK Tools: Issue #2099 Invalid chunk type
    – Andrew T.
    Feb 19 at 1:50
  • 1
    Thanks, i resolved with `apktool d -f -r netflix.apk (my apk test).
    – Dakota
    Feb 23 at 20:17
  • @Dakota -f -r may not be the best way. Now, you can build from the latest source. Jul 5 at 8:19
0

Please use Apktool v2.5.1-0a7b84-SNAPSHOT to decompile the apk. This will be fixed in v2.5.1, which is not released yet to the public

here is the link https://drive.google.com/file/d/1RmHwBD4DnDHt6RIN1Ua2gHE6F8sPqJ0O/view?usp=sharing

2
  • Based on the comment, looks like this will be fixed in v2.5.1, which is not released yet to the public. That said, I got access denied to Google Drive (though, why is it on Google Drive?).
    – Andrew T.
    Jun 22 at 10:39
  • Hi Andrew - Please check the link again. It should work. It is on google drive as I found it earlier somewhere to decompile an apk , can't locate that place on the internet. I have it on my c://windows location. Jun 22 at 12:47
0

Here is my powerful tool Decompiles almost every apk!

https://github.com/kikfox/kikfox

0

If you might be a bit suspicious of using a jar from

  • a not-so-well-known fork of apktool (kikfox) ; or
  • a Google Drive link

You may be pleased to know that you can build it yourself rather easily from the official APKtool github site, following the easy-to-follow official instructions. It just takes a few minutes.

I tried with an apk that had been giving this error.

Using apktool_2.5.0.jar (the most recent release, Dec 2020), from Apktool release site, the error was seen.

Building apktool from the source, and trying on the same apk, it worked perfectly without the error.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.