I am running LineageOS 16 on a Redmi 4X device.

I tried installing the relevant opengapps pico version selecting ARM64 and Android 9.

I booted to TWRP, selected install and clicked on the opengapps zip file. It installed successfully with absolutely NO error code whatsoever. I then cleared Dalvik/cache(TWRP menu after installing opengapps) and rebooted to system.

I ran through setup and it all finished smoothly. I can install apps from the play store and all services too are working.

However this keeps happening and android says that setup keeps crashing.

However this keeps happening and android says that setup keeps crashing.

I then redownloaded the opengapps zip again,rebooted to TWRP and installed it again. There was no error message. This time I booted to system without clearing Dalvik/Cache.

I ran through setup again. Everything happened properly, all my google stuff is working but again this setup screen keeps reappearing and Android keeps saying that setup keeps crashing.

crashes right after this screen when i click not now It crashes right after this screen when I click not now.

Even now this notification is always present in the notification bar. All my google apps are working but this is still in the notification bar!!

Surprisingly all my google apps are still working perfectly including play store,gmail,classroom. I can also call, get messages and do everything else a phone is supposed to do.

This thread talks about bootloop which is definitely NOT my issue. I didn't find any other thread related to santoni+lineageos16.

This is how I went about rooting my device.

I don't know how to obtain android system logs/logs relevant to opengapps so I am unable to post any of them. I will really appreciate any help I get since this is becoming quite annoying.

  • in addition to Morpheus you could also try older open_gapps releases. make sure to format system + data + cache before flashing lineageos + gapps + addonsu
    – alecxs
    Feb 26, 2021 at 9:51
  • refer to 4. + 5. on LineageOS Installation instructions
    – alecxs
    Feb 26, 2021 at 12:14

2 Answers 2

  • make sure you flashed right version
  • try flashing another package but same version
  • Possible bug on Rom try Contact on XDA Devlopers

Ok I have solved my own question(again)!!

Turns out Redmi Phones have some problems with encryption which I figured out after reading this section.

When I had initially installed my system, I didn't Format the storage, I only wiped the data on it. I feel this was the cause of the problem.

What I have done since is, booted into TWRP, formatted storage after wiping data then I tried installing LineageOS.

Unfortunately that didn't work because LineageOS needs Magisk binaries to function(I expect because of their inbuilt control superuser access feature).

So I wiped all data again,installed Magisk, then I installed the exact same pico opengapps version and this time it worked flawlessly.

When I had installed ArrowOS on my Lenovo Vibe K5 Plus, I hadn't formatted it either and I had installed ArrowOS before Magisk. However it worked because that phone didn't have any funky encryption going on and ArrowOS doesn't have any built-in "superuser access control".

Hence for anyone new to rooting I would advise to format the storage first to avoid any problems down the road.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .