4

I have an Android Head unit in my car running Android 8.1 It has Google Assistant and almost all of the voice commands I've tried work normally except for making calls with the command "call Mom & Dad". My phone is connected to the Head Unit through Bluetooth. It is running an AOSP version of Android 10. I can manually make and receive calls successfully on the head unit through the phone Bluetooth app that comes with the head unit.

Assistant recognizes the command and then displays "App is not installed." in a toast message. After that, it shows the command that was just spoken. There is a button next to the command that says "Call". When I press this button, it successfully brings up the Bluetooth app and makes the call.

I've tried the following with no change:

  • installed Google Contacts
  • installed an XDA version of the Google phone app as the Google Phone app does not show up in the Play store on my head unit
  • I've made sure all permissions have been turned on for the Google app
  • I installed an app called GVC CallHandler for Joying

When I try to do the voice call on my phone, it works. Initially, I made the call through the standard Google phone app. I then installed the GVC CallHandler app on my phone and selected it to make the call. Assistant tried, but when the GVC CallHandler took over, there is an exception saying that the Joying Bluetooth app was not found...which is correct when run on my phone...and that can be found in the app source.

The GVC CallHandler is not used and/or is not an option to make a voice call when I voice "Call mom & dad" on my head unit. After installing this GVC CallHandler on my head unit, when I pressed the Google Assistant "Call" button described above, then I am asked to choose between the Bluetooth app and the GVC CallHandler app.

From my research, I believe the message "App is not installed" is shown when no activity is found in Android to handle the intent being invoked. I'm not sure what intent is being called and don't know how to find out what intent is being called. I have the source for GVC CallHandler. It's an app from XDA that is available on the Play Store. GVC CallHandler XDA thread and the post with the source.

GVC CallHandler is an app that was previously created to modify the number being called to make it into a format that would work in the built-in dialer. It would remove characters such as "(", "+", etc.

So, any help to determine and address the "App isn't installed." message as described above would be great. What I'd like to do is say "Call Mom & Dad" and have the call go through my Bluetooth connected phone to make the call.

Addition: This happens to any and all contacts that I've tried.

Addition: The intention of this is to make calls through the Bluetooth attached phone.

Addition: While testing this again, I was able to find this in the logs related to the request to make a voice call:

android.intent.action.CALL dat=tel:xxxxxxxxx flg=0x1000000000 pkg=com.android.server.telecom (has extras)

This was followed by a failure to find the activity and/or the telecom package. I'm currently looking into this.

Thank you

6
  • Just want to clarify, does the call work if you try to call another one of your contacts? Or does it not work on any of your contacts? For example, if you said 'Call Dave', does it call Dave?
    – 1990clb
    Mar 2, 2021 at 14:10
  • The same thing happens for any and all contacts that I've tried. I've clarified and added text to the question/description.
    – Sikorsky
    Mar 2, 2021 at 16:23
  • "When I try to do the voice call on my phone, it works. Initially, I made the call through the standard Google phone app. I then installed the GVC CallHandler app on my phone and selected it to make the call." If you remove "GVC CallHandler app", are you able to use the assistant to make calls? Mar 2, 2021 at 17:17
  • The description about it working on my phone is to determine the "correct" way for Google Assistant to work on my phone. On my head unit, it did not come with the Google Phone app, as described. When I installed the XDA version of the Google Phone app, it still did not work and returned "App isn't installed". So, I tried "Call Mom & Dad" without the phone app and without GVC. I then installed the XDA Google Phone App and lastly, I tried it with the XDA Google Phone App and the GVC CallHandler and in all cases, the "App isn't installed" message was displayed.
    – Sikorsky
    Mar 2, 2021 at 20:05
  • 1
    Yes, the Google app is trained for my voice. As described, it recognizes my commands...it just doesn't bring up the dialer for the call command...it displays "App isn't installed" when I ask it to make a call. It is updated to the latest version. All apps are up to date. As for training including the call command, when training the voice, you are only asked to say "OK Google" and/or "Hey Google".
    – Sikorsky
    Mar 3, 2021 at 8:58

1 Answer 1

1

I thought I'd come back and post an update / conclusion to this question.

With the help of others, it was determined that the Android Telecom server on my Android Head Unit was missing code to handle the voice call. After replacing it and then adding a custom phone dialer modified to pass the call information to the GVC CallHandler, which then passes the information to the Bluetooth attached phone, the voice calling worked.

Details can be found on the XDA forums under the General / Android Auto / Android Head Units forum in the thread named "Modding your Joying/FYT SC9853i unit without root", page 31.

Note: I thought originally that this was a common problem. However, this is not a general problem with Android but a specific problem with my head unit and possibly other FYT head units based on the Intel sc9853i CPU running Android 8.1 This may also apply to other units, but you'll have to go through and determine that on your own.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .