I have a "LENOVO Tab 2 A10-30" which got frozen after the update in the startup loop - did not start after displaying the Lenovo logo. I decided to reinstall it with the LineageOS, and for that I needed (according the articles) to do oem unlock. According articles I should get the OEM unlock key from settings or allow it in the settings - which I can't access as the device won't boot up.

So I tried bunch of commands from the commandline (ubuntu 20.04), I could not OEM unlock, but I was able to install LineageOS just fine. My question is - how come that it worked, even though it should not be able to unlock the OEM? What happened there?

Started device with holding vol up:

$ adb devices
List of devices attached
0123456789ABCDEF    sideload

Then I am not sure now what I selected in the menu, but then I went:

$ fastboot devices
84afc61e    fastboot

$ fastboot oem unlock
FAILED (remote: oem unlock is not allowed)
finished. total time: 0.002s

$ fastboot oem unlock-go
FAILED (remote: oem unlock is not allowed)
finished. total time: 0.002s

$ fastboot oem get_unlock_data
FAILED (remote: unknown command)
finished. total time: 0.002s

fastboot oem device-info
(bootloader)    Device tampered: false
(bootloader)    Device unlocked: false
(bootloader)    Device critical unlocked: true
(bootloader)    Charger screen enabled: true
(bootloader)    Display panel: 
OKAY [  0.007s]
finished. total time: 0.007s

But I tried to flash in the TWRP recovery image anyhow:

$ fastboot flash recovery recovery.img
target reported max download size of 262144000 bytes
sending 'recovery' (11700 KB)...
OKAY [  0.446s]
writing 'recovery'...
OKAY [  0.947s]
finished. total time: 1.393s

$ fastboot boot recovery.img
downloading 'boot.img'...
OKAY [  0.449s]
OKAY [  0.023s]
finished. total time: 0.471s

After that, with volume up on boot I got in to TWRP menu; where I installed gaps and LineageOS zips, and after reboot it was just there.

My research links:

  • your bootloader is already unlocked (fastboot flash works only on unlocked bootloader)
    – alecxs
    Commented Mar 3, 2021 at 16:59

1 Answer 1


The official way does not always work, if your phone and flashing are ok, don't touch them is the idea.

Official way to unlock a bootloader, its different for different phones, but it I post a general overview:

  1. Back Up Anything You Want to Keep
  2. Use Android SDK or the light verision of the SDK called platform tools and the IMEI of your phone to get an unlock key for the bootloder. The unlock key or the procedure to get it can be found on your manufacturer's site.
  3. Go to fastboot mode and enter: fastboot oem unlock UNLOCK_KEY

Read more here:

This is for Sony devices.

Unlocking a locked bootloader will wipe all user data (but not the ROM) from the device. This is a security mechanism, so you can't get at the data on a phone by installing your own ROM on it.

Its locked for security reasons, because it controls all the hardware, independantly from the operating system.

You can read more about bootloaders here.

  • That doesn't make sense at all. Bootloader unlocking is not hit and trial. If the functionality is there to provide lock/unlock support, it should always work (short of a bug that may cause a problem).
    – Firelord
    Commented Mar 4, 2021 at 12:46
  • If you think that all the phones produced today make sense, its not so. I have tried it with both options and I have successfully installed with both options, despite that OEM unlocking was required and I recommend to use the official way of unlocking your bootloader. I am also following stack exchange's rulles of not including unnecessary information(including Hi and goodbye) and make things as simple as possible.
    – CFCBazar
    Commented Mar 5, 2021 at 11:40
  • I downvoted this answer... If you can provide some peer supported documentation for this, I will change my vote, but this seems like a terrible answer.
    – acejavelin
    Commented Mar 5, 2021 at 18:37
  • although the question is only about "what happened" - if you at least descripe official way of unlocking bootloader including all steps (LineageOS) so that MiroJanosik can solve his issue "fastboot oem unlock FAILED (remote: oem unlock is not allowed)" - and maybe explanation why "fastboot oem get_unlock_data FAILED (remote: unknown command)" not working - we will upvote as useful answer :)
    – alecxs
    Commented Mar 6, 2021 at 8:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .