2

Device: itel A11, Android 6

Before the installation of magisk v22, my magisk installation was working fine, so I updated the magisk through direct installation and rebooted my phone but magisk manager wasn't detecting magisk. I tried flashing magisk on my boot image and flashed the patched image with fastboot and spd flash tool but magisk manager wasn't still detecting magisk. I updated to the latest canary version and tried the same thing but to no avail, so I tried flashing my stock ROM but replaced my boot image with the patched boot image still nothing. Today I came across this thread Magisk issue :Device rooted but Magisk not installed that shows exactly the problem I have and he solved the problem by uninstalling the repackaged magisk manager, but now my problem is I flashed my phone and I doubt if the repackaged magisk manager will still be in the phone but why is magisk manager not still detecting magisk magisk app screenshot

5
  • This happened to me. Here is what I did. I uninstalled Magisk Manager app. Downloaded latest Magisk apk from GitHub. Renamed its extension to ZIP. Went into recovery and flashed that zip. Rebooted and Magisk Manager was installed and was working fine. – Firelord Mar 12 at 15:57
  • @Firelord signature verification failed and I can't use custom recovery because they don't support my device – Jeffrey Orazulike Mar 12 at 20:06
  • Unhiding of Magisk manager is essential. Please do post your fix afterwards- for now , I am deleting my answer(not relevant) – beeshyams Mar 13 at 11:04
  • @beeshyams, I can't un-hide magisk manager since I flashed my device with my stock ROM, except the app remains even after the phone being flashed – Jeffrey Orazulike Mar 17 at 10:20
  • Very unusual. I would suggest make a backup of data, wipe data, flash stock ROM and patch boot image for root – beeshyams Mar 17 at 10:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.