1

I rooted my Lenovo Vibe K5 Plus, installed Magisk,Arrow OS ver 10, opengapps pico and it was all going very well until I applied the recent update of Arrow OS with 5 Mar 2021 patch.

I downloaded the zip, booted to TWRP, selected Install and pointed to the ZIP file. Then I booted to system without clearing Dalvik/Cache. Then the problems started.

I would download files from the internet and brave would say download failed while the file would be present. However checksums wouldn't match when I checked in my pc. The default Files app wouldn't be able to delete files. However the rest of the system was fully functional, network stuff, bluetooth browsing everything worked.

Another strange issue was that no matter what system sounds wouldn't just work. Alarms, timers included. However going to youtube.com on brave would play audio just fine. My music app also worked perfectly. All notification sounds were set at maximum.

I first noticed this issue when trying to use Vanced Youtube which would crash whenever I tried to play a video.

Then today, I booted to TWRP, wiped all data and formatted storage. I then flashed ArrowOS latest version again, wiped Dalvik and booted to system, it started up normally and worked fine. So I decided to install Magisk(obviously) and booted into TWRP. When I tried it to install it though, TWRP crashed(I think) and booted to system. I tried it a few times and it happened every time. No errors were shown.

Thinking it was an issue with ArrowOS, I booted into recovery and selected wipe but TWRP again crashed and booted to system. So I decided to repair the filesystems. I booted into TWRP, selected Wipe then Advanced Wipe. I selected System and then Repair filesystem. I got an error.

/sbin/e2fsck -fp /dev/block/mmcblk0p23 process ended with error: 1
Unable to repair System

But when I tried with the Data partition, it worked fine. I then rebooted to recovery and tried to repair the system partition again and this time I got no error(strange since I did literally nothing different)

So anyways, I decided that ArrowOS was the culprit and I should switch to a different ROM, so I downloaded AOSP Extended, formatted everything on my phone from TWRP.

Then I installed Magisk (on a previous phone this had helped a lot, ie: installing Magisk before installing LineageOS, the custom ROM). It completed properly. I then rebooted to recovery, transferred the ZIP of AEX(hash verified btw) and installed it. It completed without any errors. I wiped Dalvik and booted to system.

The Magisk Manager is not present in the app menu.

I need Gapps so I transferred the OpenGapps zip to my phone from my PC(pico for android 10 ) and tried to install it from TWRP. TWRP crashed and booted into system.

OpenGapps are not present, magisk manager is not present and TWRP won't install anything, it will just crash and reboot to system.

I want to know if there are any software fixes I could try to apply before assuming that it is indeed a corrupted storage, the phone is about 5 years old at this point. I think that's what it may be but I want to be sure and would appreciate your views and suggestions.

What I have found scourging online -

This thread which I couldn't make any sense of.

This thread. I tried the fix, it gave no error but it isn't working for me either.

This thread but my device is not covered.

Any and all help is appreciated since this in my only working phone.

11
  • use older Magisk version. use recommended rooting method (no TWRP needed). use older TWRP version – alecxs Mar 17 at 17:50
  • but on ArrowOS page it is marked as "official" and that it was well maintained. Also when I went through the thread there seemed to be no complaints in recent times so I assumed that it was stable. I formatted everything, changed file system of /data to ext4 and then again to f2fs. Then I tried it all again but it didn't work. So I downloaded Orange Fox recovery which was still in beta state and i tried flashing the latest ROM(the one where all the problems started) and it worked perfectly fine. I haven't installed OpenGapps yet but the ROM+ Magisk is working fine. – linux_enthusiast Mar 18 at 5:47
  • This leads me to believe that perhaps it is some sort of TWRP bug but I can't understand just where the problem is because I didn't get any error while flashing the ROM. Beta Orange Fox actually did the job better than stable and officially maintained TWRP. I would appreciate it if you could tell me where I could have found logs for TWRP as I use TWRP in one of my other devices. – linux_enthusiast Mar 18 at 5:50
  • What custom ROM do you recommend? How is LineageOS, AOSP Extended? How do I know if a ROM's kernel has been tweaked? – linux_enthusiast Mar 18 at 9:21
  • 1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.