14

I have a new Samsung Galaxy S2 SkyRocket and the native mail program doesn't delete my IMAP mail from my server. When I view my mail on my PC, I'm still seeing the emails I deleted on the phone.

The Samsung tech told me I needed to uncheck the "Leave a copy on server" option in my mail client on my PC; however, Thunderbird 12.0.1 doesn't have that option (and personally, I fail to see how that has anything to do with my phone's mail client.)

Does anyone have an idea on how to set my phone so that it deletes those emails?

Thanks!

9
  • As mentioned in my comments below, "Leave a copy on server" is normally associated with POP3 accounts, not IMAP. There is no corresponding setting on Android mail. Are you able to check your mail on the server (via webmail)? Is it really still on the server? Or is it just stored/cached by Thunderbird?
    – MrWhite
    May 28, 2012 at 16:25
  • Also, when you send email (from Android mail), does it appear in the Sent folder on the server? ...And in Thunderbird?
    – MrWhite
    May 28, 2012 at 16:59
  • @w3d - Yes, I can check my mail via webmail and the mail I delete via Android mail is still on the server. Also, the mail I send from Android mail is not appearing in my Sent folder on the server nor in Thunderbird.
    – Yazmin
    May 28, 2012 at 22:54
  • It is behaving like a POP3 account?! Do you have an "IMAP path prefix" set on Android mail? It is like your mail server is not responding to the IMAP requests (a guess)? Just to confirm... I have an IMAP account set up on Android mail (Version 4.1) and Thunderbird and all appears to work OK.
    – MrWhite
    May 29, 2012 at 9:35
  • @w3d - I would say it's behaving like a POP3 account. I don't have an IMAP path prefix set, because I don't have that option. I deleted the account and walked through the automatic setup, without being offered the option to set the path prefix. So, I deleted the account again and walked through the setup manually. It allowed me to setup a path prefix, but sent mails still don't appear in the sent mail online, and deleted emails only appear read in Thunderbird. (I have v3.0.0.1 of Android Email.)
    – Yazmin
    May 29, 2012 at 13:59

2 Answers 2

4

Unbelievably this bug is still outstanding as of Android 4.0.4.

http://code.google.com/p/android/issues/detail?id=1029

The only fix for this is to use a different email app. Most people end up switching to GMail.

Not happy. I miss my Nokia N900.

2
  • Android 2.3.6. has got this bug too. It's unbelievable!!! In 2013 you buy a new Android 2.3.6 phome (Samsung Galaxy GT-S7500) and the default email client does not delete messages. Google don't you have other ways to convince people using Gmail?! To whom it may be interested, both K-9 Mail and AquaMail are two cool apps that do not have this ominous bug. Mar 21, 2013 at 16:43
  • Only App that handled imap well I could find was K-9
    – Colin
    Oct 9, 2014 at 19:43
0

You change the "Leave a copy on the server" option on the Android mail client.

2
  • @rm-vanda - That is what I would have thought, but that is not what he typed. We were on chat, so had to read it twice to make sure I wasn't just imagining things. Which is why we got into the discussion on how to change it on my Thunderbird client. Now, supposing I have that option on my Android client, do you know where I can locate it? Thanks!
    – Yazmin
    May 27, 2012 at 1:10
  • 1
    -1 "Leave a copy on the server" is a setting normally associated with POP3, not IMAP. And neither Thunderbird nor the Android mail client has this setting under IMAP. The Android mail client does not even have this setting under POP3 either.
    – MrWhite
    May 28, 2012 at 16:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .