1

I'm having a very strange problem today with my Galaxy S10+.

I had an update yesterday evening, and all of today it's been broken in a weird way. This'll be a longish post because I want to be really clear about the problems I'm having and explain what I've done so far to try fix it. Right off the bat I want to note that these problems are not exclusive to my SD card. My SD card works just fine and my pictures are stored across both my internal storage and the SD card. I've tried most of my troubleshooting with and without it in.

These problems occurred immediately after I finished an update. The Software Update Information says "G975FXXU9FUBD / G975FOTF9FUBD / G975FXXU9DUBD"

Basically, when I open the stock Gallery app, it shows absolutely nothing. None of my pictures or albums show at all. However, the automatically generated Stories work just fine. I can't select anything, I can't highlight anything, I can't change anything. All I see is a blank screen where I can swipe endlessly between Pictures and Albums and see a whole lot of nothing.

My files are perfectly fine and safe from what I can see. I've hooked it up to my computer and nothing is missing, damaged, broken or corrupted. They are all there in the My Files app and show all the thumbnails for the pictures. I've downloaded another Gallery app from the Play Store and all the pictures are there in the right order and the albums are there too.

But, if I say open a picture in My Files and click Gallery as the app to open the image with, it'll hang for a while then open a black screen with no buttons on it except the home bar, and all I can do is back out of it. Strangely, when I open the app tray after this, it'll only show the My Files app being open and not Gallery.

There are two very strange aspects to my problem too - I can't take photos with the camera or screenshots.

The Camera app won't save photos no matter whether I choose to point them to the internal storage or the SD card. It'll show the little preview box showing a picture was taken and do the little animation, but after a while that just turns back into the generic Gallery icon, says "Warning, camera failed" and closes itself.

If I'm quick and click on the icon that shows the picture I took, it'll just do the same thing. If I try click there before taking a picture, it'll just open the broken Gallery app after a delay of a few seconds.

I'd love to show some screenshots of my problems but I also can't take screenshots. I can press the button for it and get the overlay, but if I try to crop them or let it save, it just hangs on the overlay screen and I can't interact with anything and can only back out.

I can still save photos from online or from apps like Twitter, and apps like Messenger or Line which I use very often allow me to open and browse media and send pictures just fine. They also let me save pictures taken with the camera as long as it's through those apps and it saves those photos as I've set it in the settings of those apps, and I can see them in the My Files app right after.

After spending the whole day googling as best I can, so far I've tried the following;

  • Booting in Safe Mode (both with and without the SD card in) - The same problem exists in Safe Mode
  • Clearing the Cache/Data for various apps like Gallery, Media and Devices, My Files, Camera and all sorts
  • Looked for files called ".nomedia" on both the phone itself and through my computer and found nothing.
  • I was going to try deleting the "com.android.gallery3d" folder as suggested in a post which sounded a lot like my problem, but turns out I don't have that folder in the directory the post suggested.
  • Using a "media rescan" app.
  • Forcing an update through the Galaxy Store but it couldn't find an update for Gallery and wouldn't let me do anything with it.
  • Pressing the "uninstall update" button on the Gallery app settings page and it remained the same. Updated it through the Galaxy Store and no prizes for guessing the outcome there.
  • Literally just turning my device off for an hour and leaving it, then back on.
  • Literally just leaving the device on, locked for an hour.
  • Literally just leaving the device on with the Gallery app open in case it needed to refresh or something.

I've tried most of these both with and without the SD card in too.

I feel the problem has to be centred around Gallery because it's only ever when an app needs to use it as a medium for saving, viewing or interacting with a picture where it has issues.

The only thing I can really see that might be causing a problem is that I've got a LOT of pictures and videos. We're talking well over ten thousand pictures spread across the internal storage and the SD card. But a day ago when it worked perfectly fine that didn't seem to be an issue.

I've been using it all day and besides the gallery thing it's worked just fine. No other apps seem to be broken or have had any weird issues. My notifications are as they normally are. It's literally just any time I need to use the Gallery app.

So far all my troubleshooting has done is bother me by deleting the wallpapers and theme/icons I had on after coming out of Safe Mode. I'm completely stumped as to what to try short of a full factory restore, and I really don't want to have to take that option.

Any help would be really appreciated.

3
  • Have you tried to clear app data/cache of the gallery app? What is wired is that you can see the files from PC via USB/MTP. Have you tested if you can copy the files to the PC and they can be opened on the PC? – Robert Mar 26 at 8:10
  • Clearing the app data and cache was one of the first things I tried, both in and out of Safe Mode. All the files work fine on the PC. I'm currently working on moving them all across to back them up, and it's slow going but working just as you would expect. I don't think it's to do with my files as they work just fine in all other apps, it's cantered around the Gallery app. – Awesomecake Mar 26 at 18:08
  • Then some Samsung specific cache and/or thumbnail file(s) on device may be corrupt. – Robert Mar 26 at 18:32
0

Okay so I seem to have fixed it. Robert gave me an idea, so I checked the button on the Apps settings page so I could view all the system apps, and then I cleared the data and cache of everything I could related even slightly to UI, media, storage, photos, videos and everything in between. I'm not sure at which point it was fixed, but it seems to have done the trick.

0

I had a very similar problem on my S10+:

  • Camera wouldn't save photos (though 3rd party camera app worked)
  • Screen capture wouldn't save
  • Opera browser wouldn't save downloads (though another browser worked)
  • Gmail wouldn't save attachments
  • Random Gmail crashes, usually 10-20 seconds after starting

It was pretty frustrating, especially the Gmail crash. Anyway, I took your advice and deleted the data/cache of various system apps one by one, then retested.

Happy to report that everything went back to normal after deleting data/cache from "Sec Media Storage"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.