I am unable to list my device under adb devices and my problem is similar to that of Mad Scientist except that in his case Windows took the Google Drivers from the android SDK.

Ever since I have installed the Cyanogenmod 7.1 on my Samsung Galaxy GT-I9000, Win 7 recognizes the device as a Portable Device, Manufacturer as Android and Location on UMBus Enumerator. WUDFRd.sys and WpdFs.dll get loaded as shown in this image

I have tried to uninstall this driver but it automatically gets installed every time I connect the device. My device always looks like a mass storage device. I am unable to install android_winusb.inf from android-sdk\extras\google\usb_driver.

Windows 7 returns an error saying -

The INF file you selected does not support this method of installation.

How do I install the correct drivers so that my device is listed in adb devices?

3 Answers 3

  1. Connect your phone
  2. Open the Windows Device Manager
  3. Open each relevant device (if more than one is shown), choose "Update Driver", and select android_winusb.inf
  • I had tried doing this more than 10 times and it hadn't worked. But today I decided to give a last try. This time my phone didn't show up as a Portable Device. Instead it came up as a Unknown Device and from then on it was a piece of cake (followed the above instructions) to install the driver and get adb up. Thanks @Matthew.
    – dexkid
    May 29, 2012 at 7:09

First got to the Driver Installation Settings. It should ask you if you want Windows Update to automatically install your drivers. Choose "No"! (You will be turning it back on when done so don't worry.)

Second go to System Properties and in the upper left click on Advanced System Properties. Click on Environment Variables and create a new one. You want your variable name to be devmgr_show_nonpresent_devices and the value to be 1.

Third head to the Device Manager and under the View tab check "Show Hidden Devices." Now uninstall all the Android related drivers, especially the ones whose icons are gray.

Restart your computer but do NOT change your settings back yet! Instead open a Command Prompt window in the folder that houses the Android drivers (.inf files) you wish to manually install. Now copy the following and paste it into the Command Prompt and change the part at the end that reads <file> to the name of the driver.

 rundll32 syssetup,SetupInfObjectInstallAction DefaultInstall 128 .\<file>.inf

If your mouse spins for a second and your desktop icons flash it's a successful install. You get a message if it isn't.

Repeat for all drivers.

Change back your Device Installation Settings to "Yes" and go about your business cause we are done here!

Now you can attach your phone to your computer.


I also contributed a lot of time to the ADB problem. (Galaxy P7510 vs Win7 64bit)
After struggling with non-offical drivers, android_winusb.inf, 64bit JDK, and even having virtualized a 32bit OS..,
finally I found a work-around! just come back to share with anyone concerns.

Reference: Connect to Android with ADB over TCP

The above instruction requires a PC which can ADB to your tablet over usb.
Better work-around is root your device firstly, and then download a adbWireless utility,
so you can switch your tablet to ADB TCP mode even without USB connection at all.


  • An answer which requires the reader to go to another site to get any useful information is not really an answer. Can you at least summarize what will be found on that other site?
    – ale
    Jun 15, 2012 at 12:58
  • Sorry (maybe forgive my English) but actually I mentioned the basic info by the sentence "Connect to Android with ADB over TCP". I just mean there are many posts/threads discussing about "How to adb connect to Android device -- via USB", but in fact "adb connect via TCP" will be a practical solution for those struggled hard (just like me) but failed to solve the problem by the USB way.
    – tiancheng
    Jun 20, 2012 at 15:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .