1

My phone's screen is broken. I want to be able to use it using a PC (I just need to use two apps for a short while). I have a password on my phone. If I remember correctly, I have USB debugging enabled. I don't know if I had ever checked the option to always allow from this computer when the allow USB debugging modal pops up. I am trying to use scrcpy to control my phone from my computer. The phone is Samsung Galaxy J7 (2016).

This is what I have tried:

I downloaded adb from here. I downloaded scrcpy from here. I moved the adb files to a folder. I moved scrcpy files to the same folder, overwriting the duplicates.

I opened the command prompt from that folder (I'm on Windows). I connected my phone to the computer using a USB cable. As soon as I connected it, I ran the command adb devices -l. This is what I got:

List of devices attached
31002adf4e2c435f       device product:j7xeltexx model:SM_J710F device:j7xelte transport_id:1

The I ran the following commands:

adb shell input swipe 600 800 150 900 300                            (swipe to get to screen with password prompt)
adb shell input text "[mypassword]"                                  (enter my password)
adb shell input keyevent 66                                          (press enter key)
scrcpy

This is what I got in the command prompt (after the last command):

INFO: scrcpy 1.17 <https://github.com/Genymobile/scrcpy>
C:\Users\[User]\Desktop\New folder (2)\scrcpy-server: 1 file pushed, 0 skipped. 5.0 MB/s (34930 bytes in 0.007s)
[server] INFO: Device: samsung SM-J710F (Android 8.1.0)
INFO: Renderer: direct3d
INFO: Initial texture: 720x1280
WARN: Device disconnected

I am stuck here, with no idea what to do. I've tried using Vysor, but it also didn't work. I'd like to stick with scrcpy, unless there is a better option. Please keep in mind that I don't intend to transfer data; I want to use two apps (one of which is the Signal app, to transfer my chats).

6
  • guesswork: your battery is fully charged. when 100% is reached usb connection is interrupted because of charging mode switch. wait for battery is drained 50% and try again. it should work, do a research for "WARN: Device disconnected"
    – alecxs
    Apr 3 at 8:18
  • if problem persist connect to usb 2.0 port / hub instead (adb might hang because sometimes usb 3.0 speed is too fast)
    – alecxs
    Apr 3 at 8:32
  • @alecxs I'm pretty sure the battery being at 100% is not the problem. I have tried this repeatedly, some times after the I had left the phone for some time without plugging it in.
    – Huzaifa
    Apr 3 at 16:03
  • do you have usb 2.0 hub?
    – alecxs
    Apr 3 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.