0

I have a Samsung galaxy S3. I used to connect it to my router via WiFi and connect to the internet. Everything was OK till I switched WiFi off and then on. It doesn't connect to the router anymore and says "WiFi not in range", But it does connect to WiFi hotspot on my other phone. I don't have the problem on my other devices. I've tried restarting the phone and it didn't work. Any ideas?

1
  • Check the WiFi channel in the router settings. Channels higher than 11 are not allowed in every country and thus some devices don't search for them if the country is not correctly configured. Therefore it is recommended to only use channel 1, 6 or 11 to avoid problems. – Robert Apr 8 at 7:15
0

If you have not changed your setup, it could be a hardware issue. You might want to check if you can still access other networks.

You may also use a Wifi Scanner application to verify that you can at least see other WiFi access points. If you don't see any other networks, then you might have issue with the WiFi in your phone.

If you do see networks, then your home WiFi might configured in a way which the phone doesn't like or support. I would have a look at you routers channels (e.g. pick one 1,6,11). Make sure you access point allows 802.11 n devices (i.e. not AC-only), since the Galaxy S3 only supports up to N.

Should it be a hardware issue and you where very determined to try and fix it yourself, you can use the resources published over at iFixit to learn how to open it and see if anything obvious is disconnected.

0

Just flashed the phone and it solved this. I still don't know what caused the problem, but it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.