0

There is an educational app in my android phone that allows me to download videos for studying them offline. I have downloaded a lot of videos and have my storage filling up to the brink because of it.

I would like to transfer those videos from my phone to my android emulator on my PC. I have opened

Internal Shared Storage > Android > data > com.emedicoz.app

It turns out to be empty! I have got 3.5 GB of data for this particular app and there is nothing showing over here! I have accessed data of other apps using this similar directory and been successful at it. But this app's data shows empty.

I have tried backing up this app using third party apps but they are not successful in backing up any data more specifically any videos. They only backup some configuration and settings.

How do I access the data of this app? My phone is not rooted and I don't have an SD card on it. Does it have any bearing?

PS: I have Android 9 PKQ1.18

2
  • The linked question might seem technical. If you can see data on "Internal Shared Storage" without root, then it's actually the "external storage". However, there's also "internal storage" that can only be accessed with root access. – Andrew T. Apr 16 at 13:12
  • I solved my problem. My device was unrooted which is why I can't view any files in the directory. I tested root access with an android emulator for the app and Tadaa! I am able to access ALL the files! 😋 – Sristy Apr 17 at 4:44