0

I can't seem to reinstall Google Play Services again.

I tried the APK file thingy from Google but it didn't work. I tried a website called APKPure.com but it also didn't work. I also tried some videos but those are for different models of devices.

I didn't know that Google Play Services plays a big role for an Android and now I can't even sign in into my Play Store account (the sign in button for the Play Store isn't working).

Also, if this helps, I use a Samsung Galaxy Tab 2 (I think it is a 2016 model).

Is there a way to fix this problem?

2
  • 2
    Google Play services is a system app which can not be reinstalled (unless your device is rooted). You should edit your question and add more background on what happened in detail and what you tried. And the story about your youtube channel is irrelevant for the question. Please just delete that part. – Robert Apr 18 at 18:31
  • While we may be sympathize with your situation, please understand that is a Q&A site for helping future readers, not a personal troubleshooting site. We all are volunteers and your urgency is not a priority. If it's very urgent, consider to bring it to service center instead. – Andrew T. Apr 19 at 6:33
1

You might want to try a trick using the Device Administrator.

  • Settings > Security > Device Administrators
  • Deactivate Android Device Manager
  • in Settings > Apps find the Google Play Services
  • Uninstall Play Services updates

This might restore the version originally shipped with your phone depending on your vendor.

Check if you can activate Play Services again in Settings > Apps > Google Play Services.

Enable Device manager again, like above.

Edit: If this does not help I'd suggest to backup your data and do a device factory reset. (see e.g. https://www.rd.com/article/factory-reset-android/)

1
  • So uhm... I removed the device Administrators (Like I don't remember when) And I THINK I did the uninstall google play services updates? I'll see if I can factory reset my device. – Baaria Tahir Apr 28 at 19:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.