1

This would be the most ridiculous brick I've encountered 😄

What I did:
Having enabled Developer options, I tried setting cibarA [XB] (Arabic when reversed) as my main language.
add cibarA languagecibarA
As I figured out now, this should be a pseudolocale.
Since not everything was reversed, I thought a restart might make even more things reversed, but it actually made my phone not able to boot (properly) after that.

Current state:
On startup, it shows the Sony logo (as usual), then a black screen with tools icon for a while (also usual), then animated Xperia logo (also usual), but after that, the animation gets stuck and remains like that. When I press the power button the screen goes black and the phone is in a kind of semi-turned-on state. Pressing the button again lights up the black screen for like half a second, the green led indicator of charging also seem to brighten a bit during the time. When I hold down the power button I get a reduced power menu:
enter image description here
I tried to hold down the Power down option to boot into Safe mode, which it did, but I ended up in the same situation, except that there is "edom efaS" written down there on that black screen :D.

I tried searching a bit, but could not find anything for such a specific case. I thought maybe using ADB (although im a noob in that) could help, but I found this post which says I would need root. Which reminds me:

My device:
Sony Xperia XZ1, non-rooted, latest official firmware, from EU (Czechia), developer options enabled, with USB debugging hopefully allowed for my PC in the past?.
I hope this is sufficient, since I cant get into the system to check for details.

Ill be glad for any tips or guides on what I can do or which you can point me to. I use my phone quite a lot on a daily basis with important stuff on it. I should be able to grasp technical terms (am an IT student), altough I havent done much Android experiments myself except rooting my older Z1 Compact a few years ago. Thanks!

EDIT:

  • I tried to get to fastboot, but it did not find my device, i guess probably would need unlocked bootloader for that?
  • I tried to use adb shell in that half-on state, but the UI is not there, so I cannot confirm anything, and on pc it still says "adb.exe: device unauthorized." and on next line "This adb server's $ADB_VENDOR_KEYS is not set".
  • I tried flash mode and Sony Flash tool, just to see what it says. It says This phone is locked and points to unlocking Bootloader. But I can see the IMEI here at least.
  • Holding Volume down and power button as described here does vibrate, lights up a black screen for a short while and then dims, and then vibrate again and does a casual startup process described above. I guess again, an unlocked bootloader needed?
  • Was able to pick up a phone call! It rang in my bluetooth headphones, so I picked it up, and then a call UI showed on the screen. Although, I was not able to move on, I found eg keypad codes here, but I cannot confirm them when in the call. After ending it I get back to the black screen. So I guess the phone actually IS booted, but just the UI is not working. Could this help?

0

You must log in to answer this question.

Browse other questions tagged .