I have installed "android-x86_64-9.0-r2.iso" using USB Bootable Drive method. I am facing two big problems here.

  1. After completion of Installation I get two options - Run android or Reboot. I clicked on reboot. My computer booted to Windows 10. The grub menu asking for which OS to boot does NOT appear. I have got UEFI Boot mode with Secure Boot off. My laptop does not support Legacy boot. What can I do about this?

  2. When I clicked on Run android after installation or when I run Android Live from the bootable USB Drive only, I don't get a cursor on the screen. My touchpad does not work. My keyboard works. Connecting an external mouse works. I have tried dual booting on my previous Dell Laptop and the touchpad used to work there. Why doesn't it work with my HP PC ?

I have searched the internet and lots of other forums regarding this and did not get any conclusive results or workable solutions. Any help would be appreciated.

  • 2
    Android-x86 is a giant hack. It is not ready for productive work. Google doesn't build a x86_64 version at all. Android-x86 should not be installed directly on any PC for productive work. Try it, test it, report bugs, repeat. Live boot and installed Android-x86 varies vastly in performance. I have seen live boot booting up fine, but installed version failing to boot because of some video driver issue! If a problem comes up with your hardware, than you and us are in the same boat. You've got to fix it yourself or seek help from a community revolving around Android-x86.
    – Firelord
    Apr 21, 2021 at 8:58
  • 1
    If your PC is going straight to Windows boot on every start/restart, than your boot device / bootloader priority needs to be changed. Check your UEFI settings for such and report its snapshot/pic in your question. Also see google.com/…
    – Firelord
    Apr 21, 2021 at 9:01
  • @Firelord What should I be changing my UEFI settings to ? Also so it might be that the issue is with Android x86 being not compatible. But I have tried other- Linux, BlissOS - Neither of them showed the boot menu. I have scowered the net for some solutions. But its either I don't exactly understand them or they don't work when I do.
    – Sristy
    Apr 21, 2021 at 14:04


You must log in to answer this question.

Browse other questions tagged .