2

I have a Galaxy S8 Edge with a broken touchscreen, and I'm trying to recover files by remote controlling it. I can see only the top half of the screen and there is touch sensitivity in only the bottom 5% or so (I can barely tap the home button). All of the options I've found require USB debugging to be enabled, which I managed to do with a mouse and some lucky clicking. I am looking at Vysor, but I can't get to that point yet so it's most likely irrelevant for this question.

I'm stuck on the "Allow USB debugging" dialog that shows up when I plug it into the computer, because I cannot have both the mouse and the data cable plugged in to the phone at the same time, and therefore cannot click OK to allow the computer access.

The OTG cable (more like an adapter, not sure if it is technically called an OTG cable since I found it in a random old box) allows both USB-C and USB-A at once, but it seems that if the data cable is connected through this, only charging is allowed.

I tried using a clicker app to click in the area where the dialog shows up after a 30 second delay, but the app apparently can't go over the dialog screens.

Is there any other way I can do this, either a different cable, a different clicker app, or a different method altogether? It seems like I'm almost there but experiencing a stupid roadblock where there shouldn't be one.

I have not tried anything with command line because I'm not familiar, but if anyone can offer more specific instructions with that, I am happy to try.

Not sure if the whole cable thing was clear, so my options are either:

Phone << USBC---USBC >> Laptop

Where I cannot use the touch screen

or

Phone << USBC---USBA << Mouse
             ---USBC << USBC---USBC >> Laptop

Where the USBC-USBC wire only allows charging

3
  • 3
    You should edit your post to include the device make/model. Also do you have a Bluetooth keyboard/mouse/gamepad to test/click approval. Apr 22, 2021 at 7:02
  • 1
    your device supports DisplayPort over HDMI Adapter, but that isn't of any use for adb. bluetooth is your way to go
    – alecxs
    Apr 23, 2021 at 11:44
  • I don't think I have a bluetooth mouse, but thanks. I'll look around for one and for a DisplayPort cable as well. If that works doesn't that mean I don't need the Vysor/remote control at all?
    – LostAF
    Apr 23, 2021 at 16:51

0

You must log in to answer this question.