2

When I try to send a picture using the standard SMS/MMS app "Messages", my Samsung S20 does NOT send it as an MMS.

Instead, it sends a plain SMS with a web link to a deep subdomain of 3gppnetwork.org (for example https://ftcontentserver.rcs.mnc001.mcc288.pub.3gppnetwork.org/cs/...etc. ).

I found these Samsung instructions on how to disable this "feature". But when I click on the "Off" icon to disable link sharing, I come to screen offering "Connect to your Samsung account" or "Continue with Google", and no other option to continue.

So how can I disable this without creating a Samsung account or giving Samsung access to a Google account, which should all be completely irrelevant to sending MMS messages.

1

The phone sending SMS messages with links instead of MMS messages was due to RCS (Rich Communication Services). It was turned on by default in my new phone.

Because it was not enabled or not available on the recipient's phone, the messaging app was sending web links instead of standard MMS messages.

But the setting to turn it off is not in the Messages app itself. It's under the general "Settings", in

Connections > More connection settings > Rich Communications

It seems that the Samsung instructions about disabling link sharing and which required a Samsung account were about some other unrelated "feature", irrelevant to my real problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.