I have redmi 4 which was working fine. But it is now switched off. When tried to switch on it shows mi logo then android logo and again switch off. It is bootloader is locked, non rooted and usb debugging not enabled. So not able to connect via adb to computer. But only able to reach fastboot and recovery. And when conneted to computer via usb and fastboot via command prompt detects and shows the serial number. I'm tring to do something in short. Otherwise flashing twrp and then os again is long route; tried but in vain. As well as tried some YouTube,Google,Chinese Mi software too. Any help is appreciated.

  • bootloader unlocked?
    – alecxs
    Apr 30, 2021 at 21:05
  • No bootloader is locked May 1, 2021 at 1:17
  • you can't flash TWRP on locked bootloader. 'fastboot oem edl' should reboot phone in EDL mode. install Qualcomm HS-USB QDLoader 9008 Driver and flash ROM with MiFlash. if still not working the emmc is weared out and device is end of life
    – alecxs
    May 1, 2021 at 6:34
  • Tried fastboot oem edl response is C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot oem edl ... **FAILED** (remote: device locked, oem edl is not allowed) finished. total time: 0.010s May 1, 2021 at 10:14
  • use deep flash cable or try modified Fastboot_edl-v2.zip or use test point method
    – alecxs
    May 1, 2021 at 15:29


You must log in to answer this question.

Browse other questions tagged .