I tried to update my OnePlus One to LineageOS 18.1, following my usual procedure:

  • do a full backup (boot, system, data excl. storage, cache) with TWRP
  • then flash the new image, along with the zip files Magisk and microG

As I then noticed that Android 11 breaks some of the apps I use, I decided to roll back the update by simply booting into recovery, restoring the backup and rebooting. However, this failed with the system being stuck in the boot animation for significantly above 10 minutes.

I then tried the following:

  • boot into TWRP
  • flash LineageOS 17.1 from the previous image I had installed (plus Magisk and microG)
  • restore my backup
  • wipe caches

Still no joy, I am still stuck in the boot animation.

Suspecting the upgrade had converted some app data in /sdcard/Android/data, I moved all app dirs starting with com.android or org.lineageos off the device. (The rest should be user app data. I do not have Google Play services installed.)

That still was not successful, I am still stuck in the startup sequence.

I have never (knowingly) encrypted any data on the device.

What gives? How can I find out where the device gets stuck, so I can hunt the error down? Wiping all user data is not an option.

  • i think the real reason was one must backup system_image instead of system because of avb/dm-verity
    – alecxs
    Commented May 2, 2021 at 12:51
  • @alecxs There is no such option in TWRP on my device.
    – user149408
    Commented May 2, 2021 at 20:16

1 Answer 1


Everything that is in the backup is safe to wipe for a test (it can be restored later).

Therefore, rebuild the system step by step:

  • wipe system, data (excl. storage) and both caches
  • reinstall LineageOS 17.1
  • boot
  • if this works, return to recovery, install Magisk and reboot
  • if the device still boots successfully, restore data and retry
  • if the device still boots successfully, copy back app data to /sdcard/Android/data (possibly one by one, or in small batches rather than all at once) and retry
  • if the device still boots successfully, restore the system partition from backup and retry

If at some point the system no longer boots (i.e. gets stuck in the boot animation or similar), you can examine the step that broke it in more detail.

In my case, it seems the backup of the System partition was faulty and caused the system to hang on boot. Since this partition does not contain any user data, it is easy to rebuild if you still have the system image: Wipe the system partition, reinstall LOS 17.1 and Magisk, wipe cache and Dalvik, then reboot. That fixed it for me.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .