1

I was deleting 2 SMS messages, I did long press on the 1st until the blue tick appeared then selected the 2nd SMS. I then quickly went to the top 3 dots to select 'Delete' and the next thing I saw is blue ticks by every SMS and 'Deleting' message on the screen. The screen refreshed and it was blank - all SMS messages deleted :-(

What are my options to recover them? I have looked at apps like Fonedog & Dr Fone but after they connect they state root is required.

My phone details; Model: Mi 5 Android version: 8.0.0 OPR1.170623.032 Android Security patch level: 2018-10-01 MIUI version: MIUI Global 10.2 Stable 10.2.2.0(0AAMIXM)

In Developer options: OEM unlocking is greyed out but it says "Bootloader is already unlocked" underneath (see screenshot below) Mi Unlock status says "Unlocked"

enter image description here

Phone has been left turned off.

If the bootloader is already unlocked - could I try to root the device (with low risk of data loss) then try Fonedog & Dr Fone recovery again? When I first got the phone I tried Kingo-root and similar apps but they failed to root the device. I didn't take it any further at the time.

OR is there a way I can dump the internal memory flash (NAND?) to pc and use data recovery to find & restore my SMS?

Your help and suggestions greatly appreciated - I had some sentimental messages I would definitely like to recover. I have removed the SIM, turned off Wifi, turned on aircraft mode and phone is turned off unused.

Thank You.

Mark

9
  • fastboot boot twrp.img, get sql database, examine with hex editor. if messages still there change deleted-flag with some forensic tool
    – alecxs
    May 3 at 11:48
  • Thank you for your reply. I am following the guide but am stuck at 'fastboot flash recovery twrp.img' - all I get is < waiting for device >. The phone is connected and rebooted into FASTBOOT with the bunny on the screen - but after 1-2 minutes it just restarts. Before I tried the "adb devices" command and it lists 1 connected device. What am I doing wrong?
    – SQL_bunny
    May 5 at 18:56
  • UPDATE: Looks like I got the latest twrp working. I'm viewing the internal storage in file explorer but there is no /data/user_de/0/com.android.providers.telephony/databases/mmssms.db showing. What am I doing wrong now? Do I need to allow modifications at the first prompt?
    – SQL_bunny
    May 5 at 19:58
  • Sorry I worked it out now. I've found the file - do I copy it off the phone to pc or is there something else I should be doing? I did search for a twrp users guide but haven't yet found a detailled English one.- if you know of one a link would be great :-)
    – SQL_bunny
    May 5 at 20:16
  • db has over 1400 id's & 600 threads (so looks good) all '1' in deleted column! I guess the next step is to get the deleted column changed back to 1 and copy the amended db back to the phone?
    – SQL_bunny
    May 5 at 22:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.