I have device Realme 3 Pro. And I am trying to install TWRP. So, I downloaded In-depth test apk and got application reviewed. Then I booted into fastboot and device is not showing in device manager. I tried to add legacy device with google usb drivers. It said drivers installed but device starting failed. Error code 10.

It detected corrupted adb interface. So, I again updated same drivers.

This time device popped up in other devices and showed an error icon. So, I again updated drivers for the device. It says drivers installation successful.

But, when i double click on icon it shows no drivers are installed.

No matter how many time i update the drivers it shows no drivers installed.

Solutions tried

  1. resetted my PC
  2. resetted my phone
  3. tried various ADB drivers for Windows
  4. tried various ADB drivers for Android interface
  5. completely wiped my PC
  6. re-installed Windows (clean install)
  7. updated Windows
  8. updated all drivers present in Windows
  9. updated BIOS
  10. updated my phone to latest version

NOTE: OEM unlocking is ON. And usb-debugging is on too.

  • 2
    The ADB driver is for ADB not for fastboot. For Fastboot you need the driver "Android bootloader Interface".
    – Robert
    May 6, 2021 at 10:49
  • @Robert I tried to install the bootloader drivers as well while keeping my phone in fastboot. But, It just installs and second after when I click on phone icon it shows no drivers are installed. It gives same result for any driver. May 6, 2021 at 13:54
  • windows driver signature enforcement
    – alecxs
    May 6, 2021 at 13:55
  • @alecxs Ofcourse I tried to install various bootloader drivers while keeping my phone in fastbootboot mode and connected with my PC. May 6, 2021 at 13:55
  • youtube.com/watch?v=71YAIw7_-kg
    – alecxs
    May 6, 2021 at 13:56

1 Answer 1


you can access your phone with fastboot command. try fastboot devices in cmd and it will show connected fastboot devices. you can see full command list with fastboot --help

if you want to install twrp, you need to enter the command:

fastboot flash recovery <your twrp image file>

but i think you need to unlock your bootloader first.

  • Welcome to Android Enthusiasts. Kindly read the question before answering
    – alecxs
    May 19, 2021 at 9:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .