Ultimately trying to install Android Auto which I succeeded in doing via the apk. It told me I was missing the Google app, Google Maps and Voice rec. I installed 2 out of 3 of these but the Google app refuses to install even from APK. It seems Google Go is factory installed with no way to uninstall so I just disabled it but still no success. Running latest Android 10. Any ideas. Thanks in advance

  • Is your device a full Android device or a light-weight Android Go?
    – Robert
    May 6, 2021 at 14:10
  • It's a Motorola E6i with the Go edition of Android 10 (I just looked it up) so does that mean there is no way to install the proper version of Android 10? Forgive my ignorance and thanks for such a quick reply! May 6, 2021 at 14:31
  • Regarding full-fledge Android 10, you might be interested in my answer (at the end). However, since I only put my suggestions based on what others have done and testified, I can't guarantee personally if it will work, or worse, brick your phone.
    – Andrew T.
    May 6, 2021 at 22:11
  • Cheers - will give it a go. May 7, 2021 at 22:09

1 Answer 1


Clear cache and data of the google play store, Google play services and Google chrome. Now reboot your phone download the app again from play store or chrome and install it, it worked for me

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .