1

I have a armv7a device and not able to install armv8a application. But I am able to install armv7a + armv8a applications.

How I am able to install armv7a + armv8a and armv7a but not armv8a applications ?

7
  • 2
    If somebody understands English and French she/he will be able to read a book written in English or French. If you only understand French it will be very hard for you to understand a book in English. ARMv7 and ARMv8a are also like languages and the CPU is like a person reading the book of a certain language. Most ARMv8 CPUs are multi language capable. ARMv7 only understand one "language". As the language is hard coded in the CPU you can't change it by software.
    – Robert
    May 6 at 18:37
  • Nice explanation by Robert, thanks! Another analogy: A newer version of your word processor has added additional "formatting elements" to the document format. It can still read the older formats fine – but the older version naturally cannot understand the new format (think *.doc vs *.docx). ARMv7 is the (older) predecessor of ARMv8, the latter added new instruction sets ARMv7 does not understand.
    – Izzy
    May 6 at 20:07
  • 1
    @Izzy Things are getting even more complicated as CPUs will be released that only support ARMv8 but not ARMv7 and then there is the new 64bit only CPU type ARMv9 (bit incompatible to ARMv8 as far as I know) which just been announced. Things will really getting complex next year's...
    – Robert
    May 6 at 20:37
  • Ouch, that's indeed bad news. So ends our "easy chain"…
    – Izzy
    May 7 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.