2

I would like to add a widget to my home screen. According to the official help page, I should touch and hold an empty space, and then tap "Widgets". However when I touch and hold an empty space on the home screen, there isn't any "Widgets" button, all I see is "Home settings" and "Wallpapers". However, I found a screenshot on internet where that button is clearly visible, the problem isn't that I'm looking in the wrong place.

My phone Screenshot of someone else's phone I found on internet

So it seems like this "Widgets" buttons exists on other phones, but it's disabled on my phone for some reason. I tried googling for why this button could be disabled, but I couldn't find anything related to my problem.

I also tried clicking on "Home settings" to see if there was anything related to widgets in there, but there wasn't. I also tried opening the settings app and searching for "widgets" in the search bar, but it didn't give any results.

In case it matters, I'm using a Motorola Moto E6i.

Why is that "Widgets" button disabled and how do I enable it?

0

1 Answer 1

3

Your phone Motorola Moto E6i is running Android 10 Go.

On Android Go the default launcher has no widget support. This is the reason this option is missing.

I am not sure if different launcher apps also face this limitation. You can try to install a different launcher app that has built-in widgets. Widgets of other apps may still be impossible because of Android Go.

3
  • If there are no widgets, then why is there the built-in Google Search widget? Also I had another built-in clock widget that I accidentally deleted. May 11, 2021 at 15:41
  • @DonaldDuck so, that's the weird thing about Android Go. Vendors can set the factory default of placing the built-in clock widget on the home screen, but the access to widget setting is disabled due to the app detecting the device running on Android Go.
    – Andrew T.
    May 11, 2021 at 15:48
  • 1
    I tried the Microsoft launcher app and it seems to support widgets. May 11, 2021 at 17:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .