3

I have a Samsung Galaxy Tab 7" Plus tablet on my hands, and I am trying to test my "large" scale layouts. The device shows up in harddrive mode on my computer (Win XP), but adb does not recognize it as a device (Note: it doesn't show ??????, it doesn't appear at all). I also tried using Samsung "Kies"- no success. It doesn't even recognize that the device is attached.

As a first step, I do have debugging mode enabled under developer settings.

Am I missing some drivers for the tablet? I checked here, but no drivers are offered- just Kies. Any help is welcomed, thanks!

Note: If running "adb devices" shows your device as ??????? kill & restart the server as described here. This is a separate issue.

6
  • have you got any solutions? I am facing the same issues Jun 5, 2012 at 11:50
  • It is not ideal, but I have been connecting the device in harddrive mode, exporting the apk from eclipse, transferring it, & then installing locally. Obviously this means that I get no adb connection. :'( Jun 5, 2012 at 13:18
  • I might try using adbWireless soon though, I've heard that it works sometimes. Else Wi-Fi Kies might work...but I doubt it. I'll get back to you about adbWireless shortly. Jun 5, 2012 at 13:21
  • After talking with a co-worker, I can verify that the Samsung Galaxy Tab 7" Plus can use adb over adbWireless successfully. Just make sure both sides are on the same network. I'll post my own result soon. Jun 5, 2012 at 13:51
  • ok, I also tried with adbwireless and it works flawlessly, until now. however, I am using adb for much more than deploying apk's. I'll let you know if something comes up. :) Jun 5, 2012 at 14:06

1 Answer 1

2

The current best, known solution is to use "adbWireless" to connect the device with one's computer over a network. Be careful to connect both devices to the same network.

If you do not have access to a wireless network, the .apk can be transferred in harddrive mode after exporting the project from eclipse. However, this route does not allow use of adb for logging, debug mode, or any other tools. (See application "aLogcat" if logcat logs are wanted)

If anyone finds other solutions, please edit this answer.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .