I'm trying to manually flash the factory image on my OnePlus 8T (using this TCD guide).

I was able to boot my phone into Fastboot mode using the volume + power keys. I'm able to execute fastboot devices and successfully flashed all images in Section 8 of the above mentioned tutorial before it gets to the fastboot reboot fastboot command (i.e. boot.img, dtbo.img, etc.)

When I try to execute fastboot reboot fastboot, I get the following error: fastboot: usage: unknown reboot target fastboot.

It seems other people have this problem as well and it's due to some changes that happened in Android 10 (my OnePlus 8T is on Android 11). Reading this XDA thread, comments #14 - #18 (inclusive) I think describe the underlying problem, but I don't understand the solution.

Do I need to execute a different command, is there a process I need to complete first?

For broader context, I was rooting my phone and got into a bootloop. Fastboot can recognize my phone but not adb. I'm trying to get a clean start by restoring it to the factory image and have successfully completed all the steps in the TCD guide except for the final step of flashing the images.

Here's a screenshot of my terminal -

enter image description here

My adb version is:

Android Debug Bridge version 1.0.39
Version 0.0.1-4500957
Installed as /usr/local/bin/adb


  • I tried fastboot reboot bootloader which does successfully reboot into bootloader, but then I cannot flash the other images. When I try, I get the error: FAILED (remote: Flashing is not allowed for Critical Partitions) which I think is because I'm not in "fastbootd" which seems to be important based on the XDA thread
  • When I try fastboot reboot recovery, I am not booted into recovery but get the same error: fastboot: usage: unknown reboot target recovery
  • I ran fastboot boot imagefv.img and got the following. My phone is now showing a screen with the OnePlus logo and the words "Fastboot Mode", but no other options.

enter image description here

1 Answer 1


I downloaded Android's SDK Platform-Tools, extracted the platform-tools folder and ran a terminal in side that directory. When I executed ./fastboot reboot fastboot it did boot into fastbootd successfully. What's weird is that I installed platform-tools, put it in my /etc/ folder, and added it to my PATHS only 2 days ago. I'm not sure why exactly this worked...

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .