Today I decided to reset the phone. I got all my backups. At the same time, I copied all the files of WhatsApp to my computer completely. now i copied Whatsapp folder to phone memory. I installed Whatsapp, I got a message on my number, then I gave permission to google drive for backups (I only store my backups locally, not on google drive) .. but no restore notification came. I don't have any messages! please help me what should i do📷

EDIT When I uninstall and reinstall WhatsApp, the question 'Do you have a backup in google drive' appears. my whatsapp chat backup is locally on my phone. I tried every way. after installing i removed all google accounts, i copied whatsapp backups folder to both sd card and internal storage but it doesn't look at local backups... please we need urgent support!

enter image description here

enter image description here

  • Hi, have you followed the steps given on the official WhatsApp Help Center?
    – Andrew T.
    Jun 1, 2021 at 3:46
  • Of course I tried. The problem is that while whatsapp is re-installing, it only looks at google drive. passes without looking at local backups reddit.com/r/whatsapp/comments/np2zjp/…
    – theoyuncu8
    Jun 1, 2021 at 7:33
  • There are similar questions asked already, and the most recent answer is to disable WhatsApp backup from Google Drive first: 1, 2. There's also the older approach mentioned on 3. Please try and let us know if any of it works. Thanks.
    – Andrew T.
    Jun 1, 2021 at 12:11
  • Yes, I've already tried all of these. it would also be approved if it worked. other than that, I installed the old whatsapp version (version 2.19.351) it said 'you have a local backup' (finally) but it didn't work this time. There is a really serious problem. I removed all my google accounts and did everything @AndrewT.
    – theoyuncu8
    Jun 1, 2021 at 12:57
  • @AndrewT. Are you going to help me? I reset my phone. and now I want to do everything properly. Please help me. a forum site
    – theoyuncu8
    Jun 2, 2021 at 9:15

1 Answer 1


Please install WhatsApp version and try again. It did the job for me.

Not the answer you're looking for? Browse other questions tagged .