Before we start, just want to make it clear that I am aware how easy it is to brick this device, and have decided to go ahead rooting and installing a custom ROM anyway. My goal currently is to use twrp to install magisk and root the phone, but I cannot get the thing to boot into twrp.

In case it matters, I'm running Miui Global with Android 10 (4/01/21 patch) on a Global phone. My device is a 6GB/64GB variant with plenty of storage available.

I've grabbed the required twrp image from the link in the XDA developers guide (https://forum.xda-developers.com/t/guide-begonia-unlock-bootloader-flash-twrp-and-root-proper.3995919/) as well as a vbmeta image for a Redmi Note 8 because I couldn't find one for the pro variant. I wouldn't expect that's an issue because they run the same OS, but because mine has a mediatek SOC I won't rule it out; if someone has the right vbmeta for me, it would be appreciated.

My procedure is as follows:

  • Boot phone into fastboot, open minimal fastboot/adb from the guide.
  • Make sure twrp.img and vbmeta.img are in the fastboot directory
  • fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img
  • fastboot erase recovery
  • fastboot flash recovery twrp.img
  • Hold power and volume up to try to boot recovery.

At this point, as long as I keep holding power+vol up the phone will make it to the "REDMI" splash screen, show me the unlocked bootloader icon, and power off. A few seconds later, it will try again to the same result. This will loop indefinitely until I stop holding volume up, at which point it happily boots into Miui; I've let it loop 5 times to be sure. If I hold just vol up (no power) once the phone turns on, like the guide says, it will pass the splash screen and simply shut off. I've tried multiple twrp and vbmeta images to the same result.

The next thing to try was to boot directly to the image. I erased recovery, flashed vbmeta, and ran 'fastboot boot twrp.img." The phone hung on the fastboot screen for about 90 seconds before shutting off, and frustratingly then rebooting into Miui like nothing happened.

If I try to boot to recovery after successfully booting Miui, it works, but I get the stock Xiaomi recovery, which will not help me root my phone. I'm running out of ideas on how to get this thing into the custom recovery. Still a little suspicious it's an AVB related issue, or some form of anti-rollback protection kicking in. Anyone here got any better ideas?

  • 1
    You can maybe try rooting with a patched image?
    – beeshyams
    Jun 3 at 4:56
  • root your device first before installing TWRP. use TWRP for mediatek chipset for exact device model code name begonia. as the xda support thread is closed for unknown reason i suggest to request android 10/11 compatible update by opening github issue instead. this TWRP should work with android 9 downgrade MIUI (guess due the change from FDE to FBE)
    – alecxs
    Jun 3 at 6:06
  • Does this answer your question? Android Verified Boot and generation of vbmeta image
    – alecxs
    Jun 3 at 6:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.