I have a Motorola Atrix (MB860) running Android 2.3.6. Just today the Wi-Fi suddenly stopped working; On the Quick Settings display it just shows "Unknown", on the phone's Wi-Fi Settings display it just shows "Error" and Wi-Fi won't turn on.

I've tried turning it off and back on several times, and I've tried pulling the battery twice. I have installed Log Collector, but looking through the log I can't see anything even remotely relevant.

Talking to AT&T (God love 'em) on a previous Wi-Fi issue several months ago, they just blew me off and said they don't help with Wi-Fi issues, so I am not confident in getting help from that direction. If I have my phone replaced, my company will force me to get an iPhone due to a new Apple-only company policy. So I am on my own.

How might I go about diagnosing the problem?


Try to search for Google the appropriate Kernel for 2.3.6 (presumably you are running on 4.5.141 firmware). Then flash it. When I say "flash", I mean a flash by CWM. Good luck.

  • 1
    Yes, that is my firmware version. What's "CWM"? I'm not sure about flashing it, it's a company phone. – Lawrence Dol Jun 4 '12 at 18:27
  • Well, if that's company gadget, then I suggest you send it over for repair; let them do it for you. However, in case you wish to perform the flash, google "CWM flashing" and follow the tutorials. Good luck. – Conqueror - Atrix 4G Jun 6 '12 at 11:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.