Trying to install all exported windows WEP Enterprise 802.1X Wireless certificates (.p12 extension) to a Samsung Android 4.0.3 tablet. With no certificate installer, Android certificate was installed from Google Play on the Tablet. The certificate file was opened, however, the error “No Certificates to Install” was displayed.

2 Answers 2


I had an issue with something similar a few years back - and I believe this thread helped (see Lynx's post about halfway down). (I know it's a bit old - but I remember it being very helpful).

I believe the certificate also needs to be very generically titled "certificate.p12" or something like that (if I recall correctly).

Make sure it's in the root of your SD card and that you're trying to install from Settings >> Security >> Install from SD card.

You can also try and use this tool (not sure how secure it is - but it might help).

  • 1
    Thank you for the replies. Update on progress of installing a WiFi cretifiacate. Used certmgr.msc in Win7 to export the cert, renamed .pfx to .p12 and copied it to Android via USB cable to local Download folder. Then go to Settings => Security => install from trusted Storage. This opens up the cert for installing. Enter PW and Name you provided in the export steps. Then Create the WiFi network, the network will try to connect and obtain an IP but never connect.
    – eec14
    Jun 7, 2012 at 14:13

Using a file manager tool, it seems that you could double click the .p12 file and it would open in the default browser and prompt you for the certificate key password. If this doesn't occur, it could be that you changed the default browser on the system and that new browser doesn't know how to read and prompt the cert password?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .