This morning, I received the Android 4.0.4 Over The Air upgrade.

After my phone rebooted, I saw the following error:

Unfortunately, Launcher has stopped.
[Report] [OK]

If I pressed OK, I would see the same error again. This was, indeed, unfortunate, because it made it impossible to run any application on the phone.

How do I fix this?

2 Answers 2


The problem was bad (or improperly upgraded?) saved data in the launcher app. Here's how I fixed it.

  1. At the dialog above, press "Report"
  2. When in the report screen, drag down the notification bar at the top of the screen.
  3. Press the settings button in the upper left of the notifications area.
  4. Tap "Apps", then "All", then find Launcher in the list. Tap Launcher.
  5. Tap "Clear Data".

You lose your home screen customizations, but at least the phone now works again.

  • Good that a full factory reset wasn't needed. Commented Jun 5, 2012 at 16:45
  • @MatthewRead: Yes, that's why I didn't call Verizon tech support; I suspected it would be the first thing they'd want me to do! Commented Jun 5, 2012 at 17:23
  • 1
    The above steps fix the problem when it happens, but the problem recurs periodically. It's happened to me several times now.
    – Alex Smith
    Commented Sep 17, 2012 at 16:01

On a Google Springboard by T-Mobile, I had the same problem. When I called them, I was told to bring it in for a reset, which I didn't want to do.

On a Springboard do the following:

  • Tap the clock
  • Tap your current internet connection to bring up the menu
  • Tap settings
  • Tap applications, then tap All
  • Tap OK on the "Unfortunately Launcher has stopped" window.
  • Tap Launcher in the list of All Applications.

Wait for the configurations to load. then tap Clear Data.

Everything worked as it should after this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .