I have my phone connected to my laptop via the USB cable and ADB is able to identify the device. When I run adb devices it returns the phone in the list of connected devices. Running the command adb shell now gives an error stating:

reloc_library cannot locate 'fdatasync'

Running any command on the terminal emulator installed on my phone also returns the same error.

Does anyone have a solution to this?

  • 1
    What device do you have? Are you rooted or running a custom ROM? – Matthew Read Jun 5 '12 at 16:44
  • I can't find anything about this error. It might be your ROM... or you may need to factory restore? – Bryan Denny Jun 5 '12 at 18:04
  • I am using a Garmin-Asus nuvifone A10. I do not have a custom ROM on the device but yes, it is rooted. – Anuj Saxena Jun 6 '12 at 5:52
  • I have already tried doing a complete factory reset but that did not help either. – Anuj Saxena Jun 6 '12 at 5:52
  • this looks related somewhat to your issue. it looks like it might be an issue with your ROM, even though it is stock. – Ryan Conrad Jun 6 '12 at 12:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.