3

As described in this answer by @irfan-latif, I am trying to boot (without flashing) my Google Pixel 3a into TWRP via the following command:

fastboot boot twrp-3.5.2_9-0-sargo.img

This failed with the following messages:

Sending 'boot.img' (65536 KB)                      OKAY [  2.028s]
Booting                                            FAILED (remote: 'Error verifying the received boot.img: Invalid Parameter')
fastboot: error: Command failed

The only things I found on this topic are:

What caused the error, can it be resolved, and if so, how?

P.S. Further details:

$ adb --version
Android Debug Bridge version 1.0.41
Version 31.0.2-7242960
$ fastboot --version
fastboot version 31.0.2-7242960
  • I have unlocked the bootloader.
  • I also tried booting the LineageOS recovery which appears to work, but continues starting Android normally instead of TWRP:
$ fastboot -v boot lineage-18.1-20210608-recovery-sargo.img
Sending 'boot.img' (65536 KB)                      OKAY [  2.004s]
Booting                                            OKAY [  7.085s]
Finished. Total time: 9.156s
9
  • you can't boot from fastboot if that option is disabled intentionally. usually workaround is temporary flashing twrp to boot, and immediately restore original boot partition before installing twrp into ramdisk. the other issue is kernel related
    – alecxs
    Commented Jun 10, 2021 at 6:18
  • @alecxs Just so I understand this: If booting from fastboot was disabled, wouldn't the Booting step (when trying to boot the LineageOS recovery) fail in the same way? Or is the fact that it says OKAY for the LineageOS recovery related to the kernel? Sorry, still wrapping my head around how this all works!
    – FriendFX
    Commented Jun 10, 2021 at 6:47
  • @alecxs So the LineageOS verifies OKAY (supposedly having been signed by the correct key) but TWRP doesn't? Will AVB prevent me from also flashing TWRP (or being able to boot TWRP after it's been flashed)? No, I haven't flashed the avbmeta partition, would I need an avbmeta.img (where from?) to be able to boot TWRP? If that's what I have to do, I'd also like to backup the current avbmeta before, how?
    – FriendFX
    Commented Jun 10, 2021 at 7:45
  • @alecxs Also, this section in the AVB docs suggests that verification shouldn't fail when in UNLOCKED state, which I think my phone is (at least that's what it says).
    – FriendFX
    Commented Jun 10, 2021 at 7:50
  • 1
    Exact same issue here on an Android 12 pixel 3. Found the same links as you, and no comment are really giving a working solution
    – Waza_Be
    Commented Dec 27, 2021 at 18:30

2 Answers 2

0

Don't know if this helps anyone or not but, I had the same issue and after two day's of attempting different things I decided to start from scratch but realized if I used the original factory image (Android 9) from: https://developers.google.com/android/images

It would likely be a lot easier to manipulate. Turns out that was all I had to do. Once I flashed it back to original everything else worked without a problem.

1
  • Thanks for your answer. To make this more useful, could you please add exact steps you followed? I.e. commands entered on the command line, in the correct order? What exactly do you mean by "flashed it back to original"?
    – FriendFX
    Commented Sep 20, 2021 at 6:02
0

Up to now, the newest factory img for Pixel3 is SP1A.210812.016.C2 (8618562) , you can flash it through Android flashing website. I can boot by twrp_3.7.0_12-0-blueline.img, you can have a try.

2
  • Your answer could be improved with additional supporting information. Please edit to add further details, such as citations or documentation, so that others can confirm that your answer is correct. You can find more information on how to write good answers in the help center.
    – Community Bot
    Commented Jun 14, 2023 at 20:38
  • Welcome to Android Enthusiasts! As I stated in my question, I would like to boot the image, explicitly without flashing it.
    – FriendFX
    Commented Jun 15, 2023 at 6:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .