My Galaxy Nexus goes into charging mode but when it isn't plugged in. The battery symbol then indicates a charging and when in suspend mode, the display turns on which drains battery rapidly. I am still able to actually charge the phone by attaching an usb cable.

The problem is largely discussed in http://forum.xda-developers.com/showthread.php?t=1427539 with different suggested solutions:

  • send device to Samsung for repair
  • use a custom ROM
  • fully drain the battery and charge it over night
  • replace USB port
  • clean USB port

I guess it is an hardware problem. But before sending the device to Samsung (and beeing without phone for a while) I would rather like trying to clean the port or other "quick" solutions. Has anybody instructions to do so?

  • I had a similar problem with my Samsung Nexus S however it was intermittent and eventually went away by itself, other people also had the problem though so it might be worth searching for the issue with the Nexus S and trying some suggested fixes.
    – Peanut
    Commented Jun 6, 2012 at 10:31

5 Answers 5


If you are familiar with such things, iFixit has a teardown report for the Galaxy Nexus, it's fairly easy to disassemble it to reach the micro USB port after step 7 and inspect it.

I use isopropyl alcohol and q-tips for cleaning normally.

I'd however not suggest you try it if you have no experience with such stuff.

  • Thanks. I could fix it myself with compressed air without even disassembling.
    – Rodja
    Commented Sep 5, 2012 at 2:37

Having worked professionally in the phone refurbishment industry, I would suggest using IPA (industrial purpose alcohol) for cleaning followed by compressed air.

DO NOT UNDER ANY CIRCUMSTANCES BLOW AIR FROM YOUR MOUTH ONTO ANY OPEN DEVICE. This can cause minor water damage from the moisture on your breath or short circuit components.


I was able to fix it just by blowing into the USB port. Try it yourself before going into rooting and disassemble.


Used a needle to poke around gently at the top of the little tab inside the USB port and compressed air. It fixed it.


easy. with a very small flathead screwdriver bend the flag towards the screen very slightly in the charging port. this will fix it. I literally just did that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .