0

A quote from here:

I have tried everything and am unable to activate the developer options on my Sasmung Galaxy S7 Edge with Android 8.0. Whenever I tap the build number repeatedly, it says that the developer mode has already been enabled. I can confirm however, that this is not the case:

  1. The "Developer Options" menu does not appear in my settings
  2. Even when using the search, these settings do not appear
  3. Some users used third party apps like "ActivityLauncher" to manually search the com.settings.Settings.$DeveloperOptions activity. I have tried this method multiple times with different apps, it doesnt work. Trying to open an activity that requires developer mode gives me an error as well.
  4. Tried restarting the phone multiple times, closing all tabs, clearing the "settings"-App cache and data. Nothing works.

I am at a loss right now... I really want to avoid resetting to factory mode because my phone has a ton of data stored on it. Any ideas on how I could solve this?

This was also true for my S8, Android 9. Though, every time it says "You are _ steps away from being a developer..." and then asks me to put in the password and then says "Developer mode has been turned on." I can repeat this many times and it will ask me for the password every time and say the same things every time and the developer options are still not there. I am equally at a loss to the OP and I'm equally unhappy about the current only solution of a factory reset. Help would be greatly appreciated!

5
  • Does this answer your question? Re-enabling Developer Options
    – Robert
    Jun 27 at 10:04
  • Try this app play.google.com/store/apps/…
    – beeshyams
    Jun 27 at 11:16
  • 1
    @Robert I am looking for a solution not a workaround.
    – Sam
    Jun 27 at 17:39
  • Have you tried to enter Developer Settings and then disable them from within? Sometimes it is possible to activate Developer options the regular way.
    – Robert
    Jun 27 at 18:05
  • I am not sure what you mean. See my answer if that answers your question.
    – Sam
    Jun 30 at 16:12
0

I found the reason it was for me: I use an internet filter called NetSpark (https://www.netsparkmobile.com/en/) which disables Developer Options as a security measure to prevent workarounds or uninstallations. It is a matter of enabling this in the Netspark settings.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.