2

I have a galaxy S20+ and a generic USB c to HDMI cable. I connected the phone to a Philips monitor but I don't see anything on the monitor and in the USB settings I only see USB controlled by: connected device. And when trying to switch it to This device, I get an error saying "couldn't switch". Not sure if this cable isn't compatible by phones or if there's any settings I can change.

3
  • Check Settings -> HDMI mode. You may have to first enable dex mode to view something on the TV.
    – Robert
    Jul 21, 2021 at 16:02
  • @robert there's not such setting in the settings
    – Lawand
    Jul 21, 2021 at 16:17
  • Just checking if you tried a different cable or monitor. On my S9, upon plugging in the 7-1 USB hub w/HDMI the device has a pop-up with "HDMI Connect" and then drops into the Samsung DeX interface on the TV. Jul 24, 2021 at 17:34

3 Answers 3

1
  1. Open the Settings menu on your Samsung device.
  2. Tap on Connections which should be the topmost setting.
  3. Now scroll to the bottom and tap on More connection settings.
  4. Select HDMI mode from the options.
  5. A small window should appear with the HDMI options — Samsung DeX and Screen mirroring.

Select either of the two based on your preference.

1
  • I don't see an HDMI option in the "more connection settings" menu. I tried with and without connecting the cable
    – Lawand
    Jul 26, 2021 at 19:57
1

Just a guess, maybe you should press dex in the drop down menu quick panel icons? You might need to edit the quick panel and drag it down.

Otherwise, you can try (search "dex settings" in settings) to enable auto start when hdmi is connected.

I find it easier to search in settings, because searching in finder requires more keywords.

Sometimes it's easier to edit the Dex settings when you first connect it wirelessly to windows, because there are more settings when it's turned on.

Finally, I'm not sure Dex needs to be used at all when connecting to a display. Check your HDMI cable if it supports the right protocols (usb 3.1, mhl, hdmi alternate mode).

And ofcourse, set the input source of your Philips dislay to HDMI.

0

It turned out it was a faulty cable. I used another cable and the connection worked without issues

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .