1

I tried to root my phone and succeeded without any errors, then I wanted to try installing a Custom ROM(lineageOS), I did it via TWRP(I forgot to reinstall TWRP before rebooting) then I tried to boot again to TWRP(as expected it was gone) then I reinstalled TWRP via fastboot(fastboot flash recovery filename.img), the command exited without any errors but when I tried to boot to recovery nothing shows up:

• Black Screen

• After a few seconds reboots back to lineage

I downloaded the latest TWRP image from the official Website and tried to install that, same command, install success and able to boot to TWRP

BUT after a few seconds in TWRP mode(idle or not) it closes and reboots back to lineage

What I tried:

• Installing older TWRP version

adb erase recovery and reinstall

Notes:

• Lineage OS works as expected

EDIT

I haven't mentioned it but what i need the most is a way to install zip files from fastboot, i can extract the zip but some OSes have system.new.dat.something and i cannot find a way to install that, if you could at least help mart with this i'd be greatful.

1

1 Answer 1

0

it is because the lineage os you're running came shipped with lineage os recovery and now the partition is someway corrupted while you tried to install twrp.

try booting to lineage turning adb on and from your computer using platform tools, execute adb shell reboot recovery

8
  • I am aware of lineage os's recovery but that's not the case, i tried to adb erase recovery and reinstall but didn't work
    – Vbrawl
    Jul 25, 2021 at 10:51
  • you disabled verified boot too before trying to install twrp ? Jul 25, 2021 at 10:54
  • get vbmeta.img and fastboot --disable-verity --disable-verification flash vbmeta vbmeta.img then flash twrp Jul 25, 2021 at 10:55
  • fastboot --disable-verity --disable-verification flash vmbeta vbmeta.img throws an error, disable verity is not recognised as an option, nor disable verification.
    – Vbrawl
    Jul 25, 2021 at 13:03
  • You are using wrong fastboot. Download latest platform-tools from google xda-developers.com/…
    – alecxs
    Jul 25, 2021 at 14:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .