1

I've just got a Nord 2.

I've installed MS Swiftkey and setup both English and Italian.

While the input itself works with both languages, all Italian works are underlined in red.

This doesn't happen with GBoard.

Also this doesn't happen in another phone of mine, same configuration.

Does anyone has any idea?

2 Answers 2

1

It doesn't happen with Gboard or the default keyboard because they're integrated with the Android system, and they have the access to the settings like "personal dictionary" in Android system; meanwhile SwiftKey is a 3rd party app, it does not have the system level access. That's why it cannot identify the languages other than system default language. In other words, Google Spell Checker works with Gboard but not SwiftKey.

The solution is to disable spell checker.

Another potential solution could be adding Italian Language in settings. Go to:

Settings --> More/Additional Settings --> Language & Region

Here add Italian along with English.

Source

Hope this helps!

0

You mentioned on another phone - it works ( aka Swiftkey Italian isnt underlined by spellchecker ) Also try putting swiftkey as default keyboard and there's a language selection ,where you put in Italian as your 1st language and Eng as second ( do that my removing all languages and then add Italian 1st then Eng )

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .