On my Samsung Galaxy S2 running ICS 4.0.4, my compass is off by 90 degrees. It shows west in the north position.

I had a similar compass problem before, and had solved it by applying this patch. Unfortunately, I've since discovered that this patch breaks my WiFi.

I have tried calibrating the compass by moving the phone in a figure 8 pattern, as well as rotating on all axis. The compass is still pointing the wrong way, though.

Is there a safe solution for fixing my compass?

  • 5
    I've read that you can calibrate your compass by rotating your phone a few times around each of its three axes. (This advice comes from the fine app play.google.com/store/apps/details?id=com.eclipsim.gpsstatus2, by the way). I can't guarantee that it helps, but when I've tried, it seemed like it might have maybe sorta kinda helped :) – offby1 Jun 9 '12 at 17:34
  • I know that for tablets the compass is actually oriented differently from phones, perhaps the app you are using is detecting your phone improperly. Have you tried a different compass application? – Mokubai Jun 9 '12 at 18:13
  • North is north, yes, but the software has to know how the detector is orientated compared to how it is going to be displaying the information. The detector is a dumb "this is how I am orientated" type device and if it is rotated differently as it is in tablets then the program makes the wrong assumption about how the sensor is physically orientated and shows the wrong information. "Device north" is in landscape mode for tablets while phone "device north" is in portrait. This generally results in the kind of problem you are seeing but the other way around (correct on phone, wrong on tablet). – Mokubai Jun 10 '12 at 10:32
  • Have you tried 1) Different apps 2) Different locations? – earthmeLon Aug 9 '12 at 18:39

Rotating around each axis clockwise then counterclockwise got the compass working on my Samsung Galaxy Victory. This particular phone's compass works correctly with the phone flat or upright.


I've discovered over time and with much frustration and experimentation, that getting all features to work is always a matter of first finding the latest ROM and kernel that are the most problem free, then seeing if any patches exist to handle any remaining issues.

In this case, I found that I after upgrading to the latest kernel and ROM, then applying the tweak in this answer, and then also applying the compass patch I had used before, I finally got all my features working. Note it was important to go in that order.

At the moment, my GPS, WiFi, USB, and compass are all working, so hopefully I can be done with playing feature-whack-a-mole for now.

  • Thanks for the hint, only did that once so far (I don't ask much here) – ce4 Aug 14 '12 at 4:54
  • This "fix" will soft-brick your phone. The SC-02C compass fix doesn't work on the GT-I9100G. – user23246 Nov 5 '12 at 11:15
  • @DenisGuy: Well, it worked for me, so you can't say that it will automatically soft-brick a phone. You can, however, say that's what it did to your phone. As always, one should be cautious with free advice gained from forums on the internet. – Questioner Nov 5 '12 at 14:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.