I have a nuumber of Android apps installed.

When I use them from desktop shortcuts of phone, they work normally but in "All apps" (having up arrow symbol) section, it only shows 4 apps: Latitude, Local, Maps and Navigation. While all other apps are not there but still installed.

So I am wondering that why and how that happened? I saw some other similar titled questions but they are different. I didn't hide any thing intentionally but not sure if I set some thing.

Please note that I am not a layman, I am a developer so when I am doing some thing then I understand what I am doing, so I think it is some thing that did automatically, may be after and because of updates of apps. I also have app2sd card so not sure if it's related.

So please some one tell if you know that how can I have my apps again under that apps section and can use it normally. My Android version is, Froyo and I'm using an HTC Wildfire.

  • This calls for investigation via adb. Maybe one of your apps causes the listing to fail: Run adb logcat and try again. You can also use the commandline package manager: pm list packages and if you suspect one uninstall it pm uninstall <pkg-name>
    – ce4
    Jun 13, 2012 at 10:17
  • 1
    are you using a stock launcher? or something like ADW or Go launcher? Jun 13, 2012 at 12:28
  • @jlehenbauer I think these were not installed.
    – Hafiz
    Jun 13, 2012 at 21:32
  • @ce4 also please note that in my settings, I go to manage applications, and then they are under "running applications", in running applications, there are all those applications present.
    – Hafiz
    Jun 13, 2012 at 21:33
  • You mean they are missing in the Play Store app? I have a similar problem: no apps under INSTALLED and few under ALL, most are missing. Apr 21, 2016 at 13:10

1 Answer 1


I solved the problem myself. I had a game installed on SD card named, Hambo, I shifted it to phone and all apps, came back to their place, what else change I did earlier was to remove updates of Android market app. So google play was removed and then I did the only change of moving one app. from SD card to phone and my problem was solved. I don't know actual reason of problem but based on what I read some where I think it was may be waiting for some update or change in some installation after the uninstallation of play update. So when I shifted an app to phone, all old things restored at their place.

  • 1
    I solved my problem by clearing data & cache for the "Google Play services" and " Google Play Store" apps. (I had apps not showing up under MyApps in the PlayStore app, I have a Nexus 5X with Android 6.0.1) Apr 21, 2016 at 13:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .