1

I'm using Whatsapp on a Samsung GT-S7582 Android 4.2.2 machine :) (I know it's old but please stick with me), ... and I would really appreciate if you could help me making it work again. (Google Plays Store build 4.6.17)

Today Whatsapp, told me it's its last day and needs to update, so ... I let it update; but it didn't get very far. I'm displayed with the Google Play and an error within it "Error retrieving information from server. DF-DFERH-01" and the "Retry" button. (the wireless is opened)

What I had tried:

  1. I knew I disabled some Google apps (like Voice search, Youtube, Hangouts, Play Books, Play Games, Play Music, Play Newsstand, Samsung Apps, Gmail, Google+, Photos, Drive) since I'm not using them, so I went to Apps > Settings > More > Application Manager, and in the 'All' tab I went and enabled them back. (now I only have these apps disabled: Weather widget, TalkBack, secWallpaperChooser, Samsung Cloud Data Relay, S Planner widget, Picasa Uploader, Photo screensavers, phase beam, music FX, market feedback agent, Hp print service plugin, face unlock, Epson Print Service, dual clock (digital), Dropbox, DropboxOOBE, ChatON, Bubles, Basic Daydreams, Backup) I restarted the phone, did the same thing but Google Play shows me the same error.

  2. I'd tried to cleanup the cache; restarted the phone but this didn't work either;

  3. I'd tried to uninstall the Google Play Store; restarted the phone but this didn't work either;

*** EDIT: I think this step only got things worst, i.e. I wasn't allowed to install a newer version of the Google App Store. So I installed the Google Play Store from this site: https://www.apkmirror.com/apk/google-inc/google-play-store/google-play-store-25-2-27-release/google-play-store-25-2-27-16-0-pr-371716608-android-apk-download/download/. Unfortunately, I get the same error when trying to update WhatsApp. ***

  1. I'd tried the Ehsan Sajjad trick from stackoverflow; restarted the phone, but it didn't work;

The most irritating thing is that once this error is displayed in Google Play Store, you are automatically shown the menu, but in settings I don't have anything useful: at the first level I have Settings and Help, and at the second level within Settings, I have some checkboxes, clear search history and some about things, together with some user controls. None of them could/will fix the issue.

Is there a way to make the Whatsapp working again? I noticed there are other things I could do like:

  1. resetting the Google Account (but I don't want to lose all my chats with my friends from Whatsapp). (performed this but it didn't help)
  2. install Google play store apk from this site - is this site safe? https://apkpure.com/google-play-store/com.android.vending (see the Edit note from the above step 3)
  3. resetting the phone to factory and really lose everything - which I would rather not want.

I don't know if this helps, but I don't have too many apps installed (one banking app, skype, M$ authenticator and one health app).

Thanks!
R

11
  • Have you tried to remove and re-add your Google account(s) on the device? Often DF-DFERH-01 means that something is wrong with the authentication information of your account stored on the phone and for re-authenticating you need to remove and re-add the account.
    – Robert
    Aug 16 at 16:49
  • No. I didn't. Am I going to loose some data/chats by doing this removal/re-addon of my google account?
    – radui
    Aug 16 at 16:54
  • 1
    Normally everything Google account related is automatically synced to the cloud so you should not lose something.
    – Robert
    Aug 16 at 16:57
  • Unfortunately, removing and adding back the google account doesn't help. I did multiple phone restarts after this.
    – radui
    Aug 17 at 7:23
  • Do you know what else I could do? Is the link safe (from the initial ticket, e.g. apkpure...)?
    – radui
    Aug 17 at 7:29
0

I'm not sure if this will work for you AND I'm NOT RESPONSIBLE of anything regarding you or/and your phone/whatsapp chats history/job/career/finances/anything else/etc... but:

  1. I had installed the GooglePlayStore from this link and then restarted my phone;
  2. I had installed the latest Whatsapp version which works on my machine, from this link and then restarted my phone;

For the moment, I can send and receive messages.

All the very best!
R

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.