1

I want to know how to use the /dev/block/zram0 in full power, but I can't apply the command swapon -p 32767 /dev/block/zram0 as it returns this:

swapon: Couldn't swapon '/dev/block/zram0': Device or resource busy

So how do I modify the actual zram's line I have in fstab.qcomto change priority?

/dev/block/zram0 none
swap defaults
zramsize=3221223823,max_comp_streams=8,zram_backingdev_size=512M

2
  • 1
    It seems that you have a wrong perception about "full power" and high priority. swappiness is a different thing. // Resource busy means it's already mounted. // To set SWAP priority in Android's fstab, you can pass swapprio mount option: android.googlesource.com/platform/system/core/+/refs/tags/…. But I don't see any point in it. Commented Aug 21, 2021 at 21:09
  • In application, how to write it in fstab? Commented Aug 21, 2021 at 22:00

0

You must log in to answer this question.

Browse other questions tagged .