1

The situation

Whenever I install TWRP, it gets replaced by stock recovery.
It doesn't boot to recovery at all the first time. But it shows a message :

Orange state
your device is unlocked and cannot be trusted
rebooting in 5 seconds

If I even managed to boot into recovery, it's the stock one that's there
* I don't boot directly to the system.
* I use Reboot Manager app to boot into fastboot, recovery.
* same results with buttons, but I prefer the app for ease of use (power button is bad).


Info

  • Bootloader : unlocked (w/ adb)
  • Root : Magisk (w/ magisk manager)
  • Model : Infinix zero 4 plus x602

Steps I tried :

1- using adb

> fastboot flash recovery recovery.img
> fastboot reboot recovery
//OR
> fastboot boot recovery.img

2- SP flash tool
same results as before

3- TWRP app
app crashes and doesn't work


what should I do to install twrp recovery?

7
  • 1
    Installing/updating the recovery while regular system boots is a common practice (may be to update the recovery after a performed system update?). I do remember that this was even used on Google's Nexus devices. You can simply boot instead of flash into custom recovery. Alternatively you would have to modify the system boot process to not overwrite your custom recovery. Not sure if there is a generic way to to so.
    – Robert
    Sep 4 at 12:32
  • @Robert , "boot instead of flash into custom recovery" I did that with fastboot boot recovery.img but it doesn't work. the screen goes off briefly them shows the message above then boots normally to the system. If I can modify the system boot that would be great
    – Roo Tenshi
    Sep 4 at 16:28
  • Hey sorry for the late feedback. I tried it now and the same result as before.
    – Roo Tenshi
    Sep 6 at 9:56
  • @how do I provide the stock recovery? twrp app is not working.
    – Roo Tenshi
    Sep 11 at 13:46
  • that's what I used. it used to be fine but now it crashes as soon as I try to agree on terms of use
    – Roo Tenshi
    Sep 16 at 19:52
1

Try to burn all the firmware again with the sp flash tool and instead of the original recovery you will burn TWRP

1
  • 1
    Please provide additional details in your answer. As it's currently written, it's hard to understand your solution.
    – Community Bot
    Sep 4 at 20:43
0

Why Stock recovery replaces my TWRP?

usually TWRP will ask for prevent updating stock recovery automatically on initial setup, it ask for swipe to allow system modifications. you can rename /system/recovery-from-boot.p manually instead.

For Samsung devices there is a service called flash_recovery that will run when the system starts up, which will restore the recovery image back to stock. TWRP itself might not solve that, therefore multidisabler flashable zip exist for some device models.

9
  • Where does it ask? on the phone after flashing? I renamed the file but I still can't get to recovery. Instead of entering recovery, it shows the "unlocked and can't be trusted" message then boots back to the system. It shows that every time I power the phone. However, I can enter bootloader mode with the app normally.
    – Roo Tenshi
    Sep 4 at 16:42
  • "unlocked and can't be trusted" will show every time you power the phone. That is expected because bootloader is unlocked (it is not the cause of your issue)
    – alecxs
    Sep 4 at 18:41
  • yes it's unlocked. I flashed twrp using fastboot flash recovery recovery.img. isn't that flashing it to recovery partition? it doesn't boot into recovery at all
    – Roo Tenshi
    Sep 4 at 18:45
  • Yes that is flashing. after flashing, type 'fastboot reboot' while keep holding Volume Up Button until you see TWRP Splash screen
    – alecxs
    Sep 4 at 18:51
  • Tried it but still didn't work. After I reboot, It shows the android splash screen (without the error message) then holds for a few seconds. Then goes black then the splash again with the error message then boots to the system.
    – Roo Tenshi
    Sep 4 at 18:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.